1.8 server with 1.12 support?

Discussion in 'Spigot Discussion' started by djkaye, Sep 13, 2017.

  1. How do they make 1.8 server which can support 1.12 clients. I know there is a protocol hack, but is there anything I should be weary off, and is there any place with all different versions of this spigot support. thanks?
     
  2. ViaVersion plugin is the way to go.
     
    • Agree Agree x 2
  3. yes ViaVersion :D
     
  4. Viaversion will do what you want, and it works very well (not just a hack). But many older versions of 1.8.x had exploits. Be sure you're running the last 1.8.8 version that was created.

    I still have people coming on my 1.8.8 server and trying to op themselves with books or creative mode signs.
     
    • Agree Agree x 1
    • Winner Winner x 1
  5. if I prevent op being executed by anybody (including console) and have op only able to be done with the ops.json, will I be safe?

    Btw its bungee and the lobby will be 1.12, so they will have to use a 1.12 client anyways.
     
  6. You'll be fine.
     
  7. If the lobby is 1.12 I don't see the point of having a 1.8 server attached, unless you just want the 1.8 PvP stuff :p
     
  8. you're spot on with the 1.8 pvp stuff.
    Also I have some plugins which can only work as late as 1.8 - and have not had permissions from the dev to update. most of the game servers will be 1.11.2 tho.
     
  9. Try it with ViaVersion you can find it here on spigot
     
  10. Splazeing

    Supporter

    Basically when running 1.8.8, you can put in the plugin ViaVersion to support all versions above 1.8.8, it's plug and play. Easy.
    Install ViaVersion on every bungeecord instance.
     
  11. You can use ViaVersion.
     

Share This Page