[1.8] Using old permissions file [PermissionsEX]

Discussion in 'Spigot Plugin Help' started by VespaLX50, Jun 17, 2015.

  1. Hello,

    Is it possible to use my old permissions file of peX (which I used on 1.7.9) on spigot 1.8? Or should I start with a new, fresh file.

    So I tried using my old one but there are some issues. I have a rank called VIP, which I want to have fly. It worked on 1.7.9 but for some reason it does not anymore. I tried this:
    /pex group vip add essentials.fly

    But the problem is, users in the group VIP still can't fly. What should I try for permissions?
     
    #1 VespaLX50, Jun 17, 2015
    Last edited: Jun 17, 2015
  2. AngelRani

    Supporter

    You can still use the old permissions file.
    What plugins do you have on your server? One might be conflicting with Essentials.
    Also, have you tried using /pex reload?
     
  3. Yes I did pex reload
    This are my plugins:
    [​IMG]
     
  4. AngelRani

    Supporter

    Maybe try the command again, but capitalize VIP?
     
  5. Didn't help :(
     
  6. AngelRani

    Supporter

    I am not sure then. I will continue trying figure it out for you though.
     
  7. Thanks, or maybe someone else
     
  8. Completely remove anything about fly from the rank, reload the plugin and try adding it again.
     
  9. Didn't help either...
     
  10. You can check the file for errors as well.
    You can do that with a parser:
    http://yaml-online-parser.appspot.com/

    It'll show you where the error resides, please attempt to fix it afterwards.

    Remember the following things when writing YAML:
    - Never use tab, it will mess your file up
    - You MUST indent your properties and lists with 1 or more spaces
    - All keys/properties are case sensitive