1.9.4 - high cpu usage - any ideas ?

Discussion in 'Performance Tweaking' started by minecraft7net, May 16, 2016.

  1. minecraft7net

    Supporter

    Hi,

    after upgrade to 1.9.4 i have high cpu usage.

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    10372 sv194a 20 0 8956828 186728 19900 S 12.3 0.6 1:32.27 java
    9123 sv191ag+ 20 0 7932424 189680 20032 S 3.7 0.7 1:45.04 java
    9127 sv181 20 0 9059248 921652 19760 S 3.7 3.2 1:22.45 java
    9079 sv191 20 0 13.752g 190780 20420 S 2.7 0.7 1:28.34 java
    9073 sv171 20 0 9029048 565040 19044 S 0.7 2.0 0:53.76 java

    where 1.7.10 take just 0.7 and 1.9.2 2.7% CPU

    [01:47:47] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-4af49dc-c5e9a16 (MC: 1.9.4) (Implementing API version 1.9.4-R0.1-SNAPSHOT)

    INVOCATION="/somewhereinsystem/bin/java -Dhttp.proxyHost=xxx.xxx.xxx.xxx -Xmx3G -Xms3G -XX:+AlwaysPreTouch -XX:+DisableExplicitGC -XX:+UseG1GC -XX:+UnlockExperimentalVMOptions -XX:MaxGCPauseMillis=45 -XX:TargetSurvivorRatio=90 -XX:G1NewSizePercent=50 -XX:G1MaxNewSizePercent=80 -XX:InitiatingHeapOccupancyPercent=10 -XX:G1MixedGCLiveThresholdPercent=50 -XX:+AggressiveOpts -XX:LargePageSizeInBytes=2M -XX:+UseLargePages -XX:+UseLargePagesInMetaspace -jar $SERVICE $OPTIONS"

    timings
    https://timings.spigotmc.org/?url=16451112
    https://timings.spigotmc.org/?url=16451120

    any ideas?

    its survival server and i can't disable eveyrhing that can break gameplay :)
     
  2. Its at 20 tps which is not laggy at all also there isn't any plugins that are lagging your server on the timings.
     
  3. minecraft7net

    Supporter

    yep but it eats alot of host CPU power :)
     
  4. I have the same problem after updating to 1.9.4. On 1.8 it was 5% of cpu usage per player and now 20% with only me online(. I noticed that
    nether - doTick
    nether - doTickPending


    eats a lot of cpu EVEN if no one is in the Nether. Server just don't unload it. I changed param chunk-gc in bukkit.yml to
    chunk-gc:
    period-in-ticks: 300
    load-threshold: 300

    and the problem remains. If you've been in the Nether onse, server never unloads it, only if manualy /lagg unloadchunks. After this command cpu usage dpors significantly., but not for long.
     
  5. minecraft7net

    Supporter

    thanks - ok changed - and we will see.

    now i'm moved from Hyper-V virtualization to KVM with CPU-Passthrough meybe this change something too
     
  6. I have updated my spigot file and looks like problem with unloading chunks is solved. Everything works ok.
     
  7. Got the same issue lately. Manually unloading the chunks works somehow. Though this is no solution.
     
  8. minecraft7net

    Supporter

    any other ideas?

    /stoplag
    /stoplag -c

    not help (?)

    /lagg unloadchunks.
    - its ClearLagg - but its only for 1.8.x

    bukkit.yml
    chunk-gc:
    period-in-ticks: 300
    load-threshold: 300

    - not help :)
     
  9. Have you updated your spigot.jar to latest version? You can check this with /ver command.
     
  10. minecraft7net

    Supporter

    :) now its. but therad was created at May 16, 2016

    [03:49:55] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-4af49dc-c5e9a16 (MC: 1.9.4) (Implementing API version 1.9.4-R0.1-SNAPSHOT)
    [03:49:55] [Server thread/INFO]: Checking version, please wait...
    [03:49:56] [Thread-13/INFO]: You are 13 version(s) behind
     
  11. minecraft7net

    Supporter

    OK - after upgrade to latest 1.9.4 - no issues.