Premium [20% OFF SALE] CMI - 240+ Commands/Insane Kits/Portals/Essentials/Economy/MySQL & SqLite/Much...

Discussion in 'Resource Discussion' started by Zrips, Feb 5, 2015.

  1. WorldLimits

    Code (Text):
    WorldLimits:
      # By setting to true fly and gamemode limitations per world will be aplied for player on world change if they dont have appropiate permission node
      Enabled: true
      # World list with default game modes
      # If player will have cmi.worldlimit.gamemode.bypass permission node, game mode wont be changed
      # Posible modes: creative, survival, adventure, spectator,
      Gamemode:
      - world:Adventure
      - world_the_end:Adventure
      - wy:Adventure
      - lda30:Adventure
    This feature does not seem to work
     



  2. sorry my cell phone sets a space between $ and 1-

    I have the following in the CustomAlias stand:
    v:
    - cmi vanish $1-

    and it does not work to put other players in Vanish.
     
  3. you need cmi.command.vanish.others
     
  4. No not inside anvil.

    Players use ./itemname thenametheywant

    So a blacklist item section could be nice for the command too ;) Or a permission I can negate for all players that prevent them to rename tripwire_hook
    @Zrips
     
  5. I have OP Permissions
     
  6. Hello and happy new year! :)

    I have a problem with the permission node cmi.command.sit.stairs. Even with this permission the players can not sit: when they click with the right button nothing happens and when they use the command /sit (or /cmi sit) they have the message "You do not have the permission...". Even giving permission to a particular member does not work. For me (admin) it works. I do not understand where this problem may come from.
    cmi.command.ping: true
    cmi.signs.shiftedit: true
    cmi.elytra.speedometer: true
    cmi.scrollpainting: true
    cmi.command.sit.stairs: true
    cmi.command.point: true

    For sign editing, we also have a strange phenomenon: depending on the day, some players can edit the signs and others can not (there is no message, nothing happens). The next day, after reboot, it changes player and those who could not edit the day before can do it. It seems random ...

    An idea?
     
    #3826 Chevels, Jan 1, 2018
    Last edited: Jan 1, 2018
  7. you need also cmi.command.sit
    If you go with the mouse on the sentence "you dont have the permission" you can see which permission miss.
     
  8. Say something? error message? permission?
    Try to activate the bossbar to see if the other player is vanished or not when you perform /v [player]
     

  9. Please fix this bug.
    Happens at 7 seconds in this video.
     
  10. Thank you, it work now :)



    On the other hand I always have the problem with the signs editing. I quote myself:
    After several tests we noticed that:
    the 1st player who connects to the server after a reboot can edit signs. Other players who log in after can not edit. There is no error message, nothing happens.

    An idea?
     
  11. @Zrips
    BIG ISSUE with interactive commands:

    Code (Text):
    test:
      Location:
      - ==: org.bukkit.Location
        world: blocscraft
        x: -1891.0
        y: 67.0
        z: -439.0
        pitch: 0.0
        yaw: 0.0
      Commands:
      - ยง4voucher ยง4give ยง4[playerName] ยง4test
     
    Plugin add the colorcodes inside the commands so when we right click the blocks, nothing happen. It generate an error in the console each time:
    Code (Text):
    [Server] INFO Unknown command. Type "/help" for help.
    The colorcodes are added EACH TIME I want to edit the command. I need to go inside the config, removed weird caracter and reload the plugin to fix the issue :(



    I also try to SHIFT+rightclick a sign to edit it. It simply do NOTHING :(
    Is it normal?


    I try to add - cooldown:999999! thecommandwashere
    I never received a cooldown message :( Normal ?

    Thanks to you
     
    #3831 maxlehot1234, Jan 2, 2018
    Last edited: Jan 2, 2018
  12. I cannot see a method for staff to check somebody's ignore list? Could you add such a feature that staff can see who a user has ignored?
     
  13. Zrips updated CMI Ranks/Kits/Portals/Essentials/MySQL/SqLite/BungeeCord with a new update entry:

    Quick fix

    Read the rest of this update entry...
     
  14. @Zrips
    Hi, I just want to know if you can add these suggestions :)

    Something like voidspawn?
    If the player sreach the void they are teleported automatically to the spawn.
    An option to blacklist few world can be really nice ;)


    Is it possible for you to add something like SpawnersOnly ? It allow mobs to spawn ONLY from spawners or with eggs.


    Something that prevent players to fly in XXXX worldguard region like NoflyZone plugin.




    I think it can be nice to have more options/plugins into the same plugin.

    CMI was a really amazing plugin.

    Hope you can add these in a future updates :)


    Also, any idea for these issues?



    Thanks again and have a nice day/night
     
  15. Anyone have an example of the Groundclean Whitelist itemType's in the config file?

    I've tried multiple formats and it still cleans the items I have listed.

    The ID of the item
    IRON_ORE
    IRON_INGOT
    IronOre
    IronIngot
     
  16. Can u add a /nv or /nightvision perm? :D
     
  17. Could you possibly add a config option to make it so blocks placed by mirror mode won't drop as normal items? (So it could be survival friendly in a way to not cause duplication of items)
     
  18. Is there an issue tracker for this plugin? I found a command that doesn't work in 1.12.2. I wanted to use the /cmi invload command but it wont work. Basically had a saved inventory for a player (cmi invsave %player%) , Cleared his inventory (/cmi clear %player%) and then tried to load using /CMI invload %player% last. and the player did not get his inventory....and yes I used the players name instead of %player% as shown.
     
  19. found another bug I think. command /cmi replaceblock wont replace air. used the command /cmi replaceblock id 0 w 4 r 0 y 68. Replaced 0 blocks. Changed the command to /cmi replaceblock id 4 w 1 r 0 y 68 and it replace all cobblestone with stone. so the command works, just not with air. which kinda makes this command redundant because I would have though you would want to replaced blocks once players have dug them out.
     
  20. Just trying to find the permission for changing nicknames.
    cmi.command.nick only allows you to change colors. "You dont have permission to change into different nick.You can change only colors."
    The only other permissions listed for /nick are bypass ones. Im sure im just missing it, but what is the perm to allow changing to a different name?