Bungee - Spigot [2LS] ExploitFixer - Professional Server AntiExploit 1.2.0

Secure your server from exploits with this professional AntiExploit system for FREE.

  1. I just dont know what to do anymore. Im trying to fix exploits but some people has false positives and issues that no other server has and fixing them just f***s the entire protection of exploitfixer. I dont know what to do anymore.
     
  2. Do what's best for the future of the plugin. You can't always satisfy everyone, Nothing is perfect. Your plugin is amazing
     
  3. Thanks, i think i found a good setting for now. Gonna push a update and i hope it doesnt cause issues :)
     
  4. LinsaFTW updated [2LS] ExploitFixer - Professional Server AntiExploit with a new update entry:

    ExploitFixer - Update 1.1.5

    Read the rest of this update entry...
     
  5. [16:12:53 WARN]: [ProtocolLib] [PacketFilterManager] [ExploitFixer] Unsupported client packet in current Minecraft version: DIFFICULTY_CHANGE[PLAY, CLIENT, 2, classNames: [net.minecraft.server.v1_13_R2.PacketPlayInDifficultyChange] (unregistered)]
    [16:12:53 WARN]: [ProtocolLib] [PacketFilterManager] [ExploitFixer] Unsupported client packet in current Minecraft version: DIFFICULTY_LOCK[PLAY, CLIENT, 16, classNames: [net.minecraft.server.v1_13_R2.PacketPlayInDifficultyLock] (unregistered)]
    [16:12:53 WARN]: [ProtocolLib] [PacketFilterManager] [ExploitFixer] Unsupported client packet in current Minecraft version: SET_JIGSAW[PLAY, CLIENT, 39, classNames: [net.minecraft.server.v1_13_R2.PacketPlayInSetJigsaw] (unregistered)]




    Good, that message appears when I turn on the console. How could I solve it? I am using it in version 1.13.2
     
  6. That cant be solved. It means that packets didnt register because they dont exist on your server version.
     
  7. Is it fixed that placeholders doesnt work?
     
  8. Probably yes, if not, disable CustomPayload check as is the check that causes the issue. (I cant seem to find the reason why some stuff is getting detected in your servers, on mine i can use placeholders and switch servers perfectly)
     
  9. No plugin is perfect. Server Ops put so much "junk" in there and sometimes they make mistakes in configs. No one can account for every situation. You know your exploitfixer has been great for me, and yet, I can not get the antibot to work quite right. Hell, there was one plugin where the poor author could not figure out why it would not work for me... it was because I was standing on a pressure plate when I was running the command. Crazy stuff happens. Just do the best you can!
     
    • Friendly Friendly x 1
  10. LinsaFTW updated [2LS] ExploitFixer - Professional Server AntiExploit with a new update entry:

    ExploitFixer - Update 1.1.8

    Read the rest of this update entry...
     
  11. Can you fix this ?
    Code (Text):
    [18:05:42 ERROR]: Could not pass event PlayerLoginEvent to ExploitFixer v1.1.5
    org.bukkit.event.EventException
            at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:310) ~[spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.PlayerList.attemptLogin(PlayerList.java:456) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.LoginListener.b(LoginListener.java:118) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.LoginListener.c(LoginListener.java:54) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.NetworkManager.a(NetworkManager.java:231) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.ServerConnection.c(ServerConnection.java:148) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:814) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            at java.lang.Thread.run(Thread.java:748) [?:1.8.0_242]
    Caused by: java.lang.NullPointerException
            at twolovers.exploitfixer.bukkit.managers.BukkitExploitPlayerManager.get(BukkitExploitPlayerManager.java:36) ~[?:?]
            at twolovers.exploitfixer.bukkit.listeners.PlayerLoginListener.onPlayerLogin(PlayerLoginListener.java:56) ~[?:?]
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_242]
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_242]
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_242]
            at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_242]
            at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]
            ... 13 more
     
  12. You are working On this plugin everyday and everyday is the new update. It is great but is it possible to this plugin will itself detect version of config and then replace the config if it is needed? It would be awesome
     
  13. No. That would remove config that people made if they changed anything.
     
  14. But now, people have to remove the config by themself and the changes are removed too
     
  15. No. If people changed the values they can just update it instead of removing it. It says to remove because most of people doesn't know how to update. Just check the github and see the changes on the config and apply them.

    I won't delete configuration if the user doesnt want to. Its instrusive.
     
  16. hey! when the plugin is enabled, players dont gain experience
     
  17. ExploitFixer doesnt interfere in experience gaining in any way.