30% packet loss on server

Discussion in 'Systems Administration' started by RiotShielder, Sep 30, 2014.

  1. I've got a server hosted by Kimsufi, currently I'm getting 30% packet loss, I'm not sure why, and as far as I know, Kimsufi won't help as they are strictly 'hardware only'

    Kimsufi Server KS-4
    Hosted in Montreal, running Ubuntu 14.04 x64

    Results of ping ts-mc.net -n 50 (I also tried 1000 packets in the past to get a better idea of what's going on, I recieved similar numbers) I've tested my connection on pingtest.net, I have 0% packet loss, so I'm thinking it has to be my server.

    [​IMG]

    I'm happy to provide any pertinent information to this, not really sure what to give as of now, I'm not really knowledgeable with networking. This disconnected me from my server every so often (Maybe once every 10-20 minutes, sometimes more) also it makes using SSH/SFTP a pain, takes forever to do anything with it.

    I've tried rebooting the server, still the same problem, I would appreciate any help.

    Thanks!
     
  2. I have a ks4 in that datacenter too, my ping is shit, but I haven't had packet problems
     
  3. Yea I got one of my staff to ping the server, they're fine as well. Not sure why this is happening though.

    Here's a traceroute, honestly don't know if it's relevant to this but if it helps..
    http://pastebin.com/WydY5ZAn
     
  4. Isn't Kimsufi ran by OVH? OVH has tons of network problems, and it could be something on their end. Also, are there any kernal updates, (updates at all), last time box was restarted.

    also, if you can provide an mtr out of the box (to a server in a different datacenter), as well as an mtr into the box (from a server outside of the datacenter), we can see where the packets are dropping.
     
  5. It seems to be something with my connection. A player and @rwsender reported no issues
     
  6. MikeA

    MikeA Retired Moderator
    Retired Benefactor

    Use WinMTR, it'll tell you on which hops there is packet loss on. Your server could be attacked, as there will be packet loss when an attack is being mitigated by VAC most of the time.
     
  7. [​IMG]
    No packet loss for me. Question, Who is your ISP and are you using Wifi or Ethernet?
     
  8. Time Warner/Roadrunner.

    Ethernet, I've already tested packet loss to my router, there's none.
     
  9. No packet loss for me either.
    ping.jpg
     
  10. [​IMG]
     
  11. MikeA

    MikeA Retired Moderator
    Retired Benefactor

    That's your connection, not OVH. The packet loss starts at your ISP :p I'm in Texas also, Charter is a great internet provider *wink wink*
     
  12. Do you have any idea on how I can resolve this?
    I'm only 17 at the moment, living with my parents so I have to use what they give me :p
     
  13. MikeA

    MikeA Retired Moderator
    Retired Benefactor

    Ask your parents to give Time Warner / RR a call and ask if there's network issues in your area. They have live chat but I doubt it's very useful for stuff like this (?)
     
  14. Start by restarting your modem. Also are you using a Router+Modem combo or What's the deal? (Modem -> Netgear -> Computer. etc)
     
  15. Eh, I'd probably have to call myself. They aren't exactly experienced in this sort of stuff

    Just a modem => router => computer
     
  16. I'm 17 and I've been calling Britsh Telecoms for years, they dont mind usually aslong as you reside in the address!
     
  17. Hmph.
    What if you ping something else, Like spigotmc.org.
     
  18. It's obvious that the problem is after the hop CISCO53132. Most probably at your ISP. Call them and explain the situation.