Premium [40% BLACK FRIDAY SALE] MYSTERYBOXES ⇒ BEST REWARDS PLUGIN ⇒ 1.8/1.9/1.10/1.11 SUPPORT [40%...

Discussion in 'Resource Discussion' started by xeRicker, Sep 17, 2015.

  1. I have this error now


    [13:12:33 ERROR]: [MysteryBoxes] Plugin MysteryBoxes v314 has failed to register events for class me.xericker.mysteryboxes.Events because org/bukkit/event/entity/EntityPickupItemEvent does not exist.
    [13:12:33 ERROR]: Error occurred while enabling MysteryBoxes v314 (Is it up to date?)
    java.lang.NoClassDefFoundError: org/bukkit/Particle
    at me.xericker.mysteryboxes.mysteryboxes.boxeffects.BoxEffectParticleTextHologram.<init>(BoxEffectParticleTextHologram.java:23) ~[?:?]
    at me.xericker.mysteryboxes.mysteryboxes.MysteryBox.<init>(MysteryBox.java:67) ~[?:?]
    at me.xericker.mysteryboxes.mysteryboxes.MysteryBoxManager.registerBoxes(MysteryBoxManager.java:53) ~[?:?]
    at me.xericker.mysteryboxes.Main.registerPlugin(Main.java:183) ~[?:?]
    at me.xericker.mysteryboxes.Main.onEnable(Main.java:95) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.reload(CraftServer.java:741) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.Bukkit.reload(Bukkit.java:535) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchCommand(CraftServer.java:641) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchServerCommand(CraftServer.java:627) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.DedicatedServer.aO(DedicatedServer.java:412) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:375) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_231]
    Caused by: java.lang.ClassNotFoundException: org.bukkit.Particle
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_231]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_231]
    ... 21 more
     
  2. In 1.8 the plugin is completely bug
     
  3. Andre_601

    Supporter

    Did you actually use the right version?
    The error complains that it can't find a class which is often caused by using older plugins (made for 1.8) on newer servers (1.14.4) or vice-verca.
     
  4. Well yes I have a spigot 1.8.8 R3 so it should normally be found
     
  5. xeRicker updated MYSTERYBOXES ✫ NEW! 1.8 + 1.14 SUPPORT ✫ LootBoxes/TreasureChests with a new update entry:

    v315

    Read the rest of this update entry...
     
  6. xeRicker updated MYSTERYBOXES [1.8/1.14] ✫ LootBoxes/TreasureChests with a new update entry:

    v316

    Read the rest of this update entry...
     
  7. Good evening, I'm really getting tired of not being able to use your plugin on my server!, I have all the same error so if this error is not settled I would like to be reimbursed or I have a dispute prc I not paid for a plugin that is not working on my server


    [21:27:35 ERROR]: [MysteryBoxes] Plugin MysteryBoxes v316 has failed to register events for class me.xericker.mysteryboxes.Events because org/bukkit/event/entity/EntityPickupItemEvent does not exist.
    [21:27:35 ERROR]: Error occurred while enabling MysteryBoxes v316 (Is it up to date?)
    java.lang.NoClassDefFoundError: org/bukkit/Particle
    at me.xericker.mysteryboxes.mysteryboxes.boxeffects.BoxEffectParticleTextHologram.<init>(BoxEffectParticleTextHologram.java:23) ~[?:?]
    at me.xericker.mysteryboxes.mysteryboxes.MysteryBox.<init>(MysteryBox.java:67) ~[?:?]
    at me.xericker.mysteryboxes.mysteryboxes.MysteryBoxManager.registerBoxes(MysteryBoxManager.java:53) ~[?:?]
    at me.xericker.mysteryboxes.Main.registerPlugin(Main.java:183) ~[?:?]
    at me.xericker.mysteryboxes.Main.onEnable(Main.java:95) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:357) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:317) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:414) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:378) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:333) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:263) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot.jar:git-Spigot-db6de12-18fbb24]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_232]
    Caused by: java.lang.ClassNotFoundException: org.bukkit.Particle
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot.jar:git-Spigot-db6de12-18fbb24]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:418) ~[?:1.8.0_232]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:351) ~[?:1.8.0_232]
    ... 16 more
     
  8. Please, use a valid jar file depending on the version of your server.

    MysteryBoxes: Spigot 1.14
    MysteryBoxesLegacy: Spigot 1.18
     
  9. xeRicker updated MYSTERYBOXES [1.8/1.14] ✫ LootBoxes/TreasureChests with a new update entry:

    v317

    Read the rest of this update entry...
     
  10. #1871 xeRicker, Nov 15, 2019
    Last edited: Nov 15, 2019
  11. Its not work for 14.4.4 its sad because this was the money i have for the plugin :(
     
  12. Hello,

    Why there is 1.8.8 support but NO 1.12.2 support ??
    There are more 1.12 server than 1.8..
     
  13. There are more PVP servers on 1.8 than 1.12.2. Most of the 1.12.2 servers are modded and might not support this plugin with forge/bukkit hybrids.

    Also, on 1.8 I've been getting an issue with extra holograms above the box.
     
    #1877 Me_Goes_RAWR, Nov 18, 2019
    Last edited: Nov 18, 2019
  14. That's stupid to support 1.8 but not 1.12, as it's approximately the same version
     
  15. There are some BIG differences between the 2 versions. a major one being the 1.9 PVP changes. I agree its a little stupid but whatever.
     
  16. Andre_601

    Supporter

    I agree that it is weird that a stoneage version (1.8) is supported, but a version which is not that old (when comparing to latest version) and that is used more according to bstats isn't.