Premium AAC (Advanced Anti Cheat) (Hack & Kill aura Blocker) [Paid]

Discussion in 'Resource Discussion' started by konsolas, Apr 28, 2015.

  1. konsolas

    Supporter

    konsolas submitted a new resource:

    AAC (Advanced Anti Cheat) (Hack Blocker) - A complete anti-cheat solution blocking every major combat hack, and many others.

    Read more about this resource...
     
    • Like x 5
    • Agree x 2
    • Funny x 1
    • Winner x 1
    • Optimistic x 1
    • Like Like x 1
    • Funny Funny x 1
    • Friendly Friendly x 1
    • Creative Creative x 1
  2. konsolas

    Supporter

    Yes. The test server is Spigot 1.8.3.
     
    #3 konsolas, Apr 28, 2015
    Last edited: Apr 28, 2015
    • Optimistic Optimistic x 1
  3. Bu eklenti sunucuda lag yapar mı?
     
    • Like Like x 1
    • Friendly Friendly x 1
  4. Arkadas Turkce Yazmissin Ingilizce Yazda Adam Anlasin :D
     
    • Winner Winner x 1
  5. konsolas

    Supporter

    No, this plugin is highly unlikely to cause lag, as no extra entities are spawned.
     
    • Agree Agree x 2
  6. konsolas

    Supporter

    • Like Like x 1
  7. Türk üz ama :) farkımız tarzımız...
     
  8. I have just purchased the plugin, I will leaave my review on the plugin soon.
     
  9. I get an error anything I try to load the plugin even though I have ProtocolLib installed.
    [16:06:18] [Server thread/ERROR]: Could not load 'plugins/AAC.jar' in folder 'plugins'
    org.bukkit.plugin.UnknownDependencyException: ProtocolLib
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:219) [spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at org.bukkit.craftbukkit.v1_8_R2.CraftServer.loadPlugins(CraftServer.java:291) [spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at net.minecraft.server.v1_8_R2.DedicatedServer.init(DedicatedServer.java:199) [spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java:522) [spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at java.lang.Thread.run(Unknown Source) [?:1.7.0_45]

    Also my new error

    16:11:28] [Server thread/ERROR]: Could not load 'plugins/AAC.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/konsolas/aac/AAC : Unsupported major.minor version 52.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at org.bukkit.craftbukkit.v1_8_R2.CraftServer.loadPlugins(CraftServer.java:291) [spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at net.minecraft.server.v1_8_R2.DedicatedServer.init(DedicatedServer.java:199) [spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java:522) [spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at java.lang.Thread.run(Unknown Source) [?:1.7.0_45]
    Caused by: java.lang.UnsupportedClassVersionError: me/konsolas/aac/AAC : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_45]
    at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_45]
    at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_45]
    at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_45]
    at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_45]
    at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_45]
    at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_45]
    at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_45]
    at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_45]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_45]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_45]
    at java.lang.Class.forName0(Native Method) ~[?:1.7.0_45]
    at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_45]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.8.3.jar:git-Spigot-52df9dd-8e5e4c1]
    ... 6 mor
     
  10. konsolas

    Supporter

  11. This is beacuse you need ProtocolLib or you have got to update it.
     
  12. Yes I used the link you put in the plugin description. I have updated it to the latest version and I am still getting the second error.
     
    • Optimistic Optimistic x 1
  13. konsolas

    Supporter

    @MC_Sandwich

    Ok, if you're sure you have the latest version of ProtocolLib in your plugins folder, please send me a PM with the full console log.

    EDIT: Your second error is caused because you are running Java 7 or Java 6. Please update to Java 8.

    UPDATE: AAC is now compatible with Java 7
     
    #14 konsolas, Apr 28, 2015
    Last edited: Apr 29, 2015
  14. samczsun

    Supporter

    @konsolas

    AAC is not detecting any hacks I'm using
     
  15. konsolas

    Supporter

    Such as? The hacks shown in the video will be detected, in those circumstances. For example, Anti-Knockback will only be detected in PvP, and FastBow will only be detected if you try to shoot arrows.

    EDIT: Oops, Somehow I forgot to put AAC on the test server.... Fixed now.

    The one plugin I try to showcase I forget to put up :/
     
    #16 konsolas, Apr 28, 2015
    Last edited: Apr 28, 2015
    • Like Like x 1
    • Funny Funny x 1
  16. samczsun

    Supporter

    #17 samczsun, Apr 28, 2015
    Last edited: Apr 28, 2015
  17. konsolas

    Supporter

    @samczsun Yeah, I forgot to enable AAC, sorry.
     
  18. Whe you test it, please wirte your opinion.
     
  19. samczsun

    Supporter

    @mark22padre

    Here's my updated review:

    Works brilliantly. The hacks are detected pretty much 100% of the time (didn't have a mouse on my so I couldn't go tryhard or test false positives). I'd say this plugin gives exactly what it promises
     
    • Like Like x 2
    • Creative Creative x 1