Accessing a localhost server without internet connection

Discussion in 'Server & Community Management' started by Ivain, Jun 10, 2018.

Thread Status:
Not open for further replies.
  1. I found this thread a few days back: https://www.spigotmc.org/threads/trying-to-access-localhost-server-offline.210613/
    When I was searching for a way to get Minecraft to let me get onto my localhosted building server while I have no internet connection. However, even following all the instructions present in that thread, it still tells me the "Authentication servers are offline" deal, which is ofc due to there not being any internet connection.

    If anyone has a clear answer for someone who is effectively a newb at server managment (the servers I'm using are either very simple or are premade), I'd be grateful.
     
  2. I haven't been on Minecraft for about a month so I might lack the experience since of not being able to test this before commenting, but couldn't you put your mc and the server in offline mode so it wouldn't be affected by the server's auth for checking the user? You could also download a plugin that allows you to still connect while the auth servers are down which can be found here (the plugin is outdated, so once my finals are up) I will look into updating it for you/releasing it as a resource if the author allows me (if he isn't inactive).
     
  3. Thats all you need to know. If I remember correctly from back in the day this message means you cannot connect to Minecraft's Authentication servers. Meaning it can't verify pirated accounts from legit. This used to happen a lot back in the day when Mojang had unreliable up-times. We had to constantly switch between online and offline modes. To fix this issue, go into your server properties and turn online mode to false. This should solve your issue and allow you to connect.

    Hope I helped, please let us know if this solves your issue and don't hesitate to ask if you need more help!
     
  4. But you also have to take in a note if the IP address was public (I am guessing it isn't since it is localhost, but still taking chances) that a user could log onto the same username (using a cracked launcher) to get onto the server.
    Yeah this would be a way to solve it, but I would also check about the method above to see if AlwaysOnline works (must be installed before the authentication servers are down)
     
  5. Based on the OPs post this is a private server just for them to build on. I wouldn't personally setup any form of protection from outside connections based on what we know from the OP.

    If this were a commercial build or rather public however, I would definitely recommend a password plugin or some other form of protection from hijacking.
     
  6. Yeah, it's literally just a "localhost" server (that's what I type into direct connect or server address) with a whitelist that has only me on it.
    As for the server properties thing, I remember looking into that file and not being able to find the ' online' setting, but I'll look again, its very possible I read over it.
     
  7. That's the feeling I got from your OP which is why I didn't feel the need to add anything extra in terms of stopping hijacking. You are the only one that can connect so there is no point :)

    No worries, the setting is right here:

    [​IMG]

    Just change that option to false and it will fix your issue. Enjoy :)
     
    • Like Like x 1
  8. Strahan

    Benefactor

    That doesn't really mean anything; a home hosted public server would also be one you can type "localhost" to direct connect with assuming you are playing on the same box that runs it.
     
    • Funny Funny x 1
  9. Well I mean if you read the next part where I talk about the whitelist having only my IGN on it, it becomes pretty obvious what it means :p.
     
    • Agree Agree x 1
  10. Anyway, the issue has indeed been solved, I just looked over it like a doofus. I can now use my localhost server while offline, at last. now I can start getting things done.
     
Thread Status:
Not open for further replies.