Adding help to commands

Discussion in 'Spigot Plugin Development' started by Markyroson, May 31, 2017.

  1. Hi there! When I do "/help servertp" in game, it lists no commands, however the plugin contains 7 commands (excluding aliases) that are listed within plugin.yml, each with a description set. Does usage need to be defined for it to show up with any help?

    Example command (of course not all of my plugin.yml):

    Code (Text):
        setshop:
            description: "Sets the shop"
            permission: ServerTP.setshop
     
    #1 Markyroson, May 31, 2017
    Last edited: May 31, 2017
  2. Yes, the description you put in the plugin.yml is the one that will be displayed in /help
     
  3. The thing is, /help does not display anything (in this case) saying "No help for setshop". @fernandopal
     
  4. Maybe you don't have the
    Code (Text):
    ServerIP.setshop
    permission
     
  5. I have tried it as an op (thanks for reminding me), however, that did not change anything. Ops do inherit all permissions, right? I am just running a bare-bones test server at the moment. @42Jamie42
     
  6. You have a permission plugin on it right? Like PermissionsEx
     
  7. No I do not but I will add one shortly. I checked it with another command that does not require any permissions and it has the same issue.

    Code (Text):
        hub:
            description: "Teleports you to the hub"
    also produces "No help for hub" (with or without the quotation marks, they were part of a test, which did not alter the result) @EexoPlays
     
  8. Display your whole plugin.yml please :)
     
  9. Here it is @NormaalBart, copied and pasted from other thread. Again, this was tested with and without the quotations, neither worked for me.

    Code (Text):
    name: ServerTP
    main: me.Markyroson.ServerTP.Main
    version: 1.92.2
    description: Adds teleportation functionalities to servers that this plugin is installed on
    author: Markyroson
    commands:
        sethub:
            description: "Sets the hub"
            permission: ServerTP.sethub
        hub:
            description: "Teleports you to the hub"
        st:
            description: Displays full list of commands
            aliases: [servertp, stp]
        setpark:
            description: "Sets the theme park"
            permission: ServerTP.setPark
        themepark:
            description: "Teleports you to the theme park"
        shop:
            description: "Teleports the player to the shop (if set)"
            permission: ServerTP.shop
        setshop:
            description: "Sets the shop"
            permission: ServerTP.setshop
     
    #9 Markyroson, May 31, 2017
    Last edited: May 31, 2017
  10. Are the commands recognized by the server? (did you registered the commands in your main if you have multiple classes?)
     
  11. Yes, the commands are recognized and do indeed all work @NormaalBart .
     
  12. Dont put them in " and see if that works.
     
  13. Thanks for the suggestion, however, as noted 3 comments above this one, I tried it with and without the quotations but sadly neither worked (as in displayed help). @TheBlackTeddy
     
  14. Hmmm. It should work. Are you doing /help <pluginname>?
     
  15. Done that as well as /help st (or other command in plugin) @TheBlackTeddy
     
    #15 Markyroson, May 31, 2017
    Last edited: Jun 4, 2017