Spigot AddLight 4.3.2

Quickly add invisible light sources

  1. I've updated AddLight to 1.10, be sure to use LightAPI 3.0.0
     
  2. The plugin is good, but I don't really understand Light intensity.
    It looks light same between 1-15.

    @hexosse
    When addlight mode is off,
    I can change block to stone_slab, glows_stone, blue wool when I right click with glowsdust
     
    #44 WindUnwaken, Jun 24, 2016
    Last edited: Jun 24, 2016
  3. I must be doing something wrong as I cannot even use the /addlight command

    28.06 12:13:34 [Server] INFO Caused by: java.lang.NoClassDefFoundError: Could not initialize class com.github.hexosse.AddLight.framework.pluginapi.message.MessageColor

    Is the error I am getting.
     
  4. Which version of AdddLight and Spigot are you using ?
     
  5. The newest versions you provided in your description. Even redid them/rebooted server clean to verify.
     
  6. Hey hexosse,
    Could you help me I get this error: http://pastebin.com/emT2nxwD
    Server is Using: PaperSpigot-1.8.8, AddLight-1.5.0, LightAPI 3.1.0
    I already tried other versions of your Plugin but nothing worked out yet.

    Regards, Noplix
     
  7. Hi, are you using spigot or paper ?
     
  8. Nope. Simply using the latest bukkit. Could it be essentials or permissionsex messing with the chat color control?
     
  9. You have to use Spigot (or a spigot fork) as I'm using the bungee message API from Spigot to format all the messages sent by the plugin to clients.
    This way nearly all my messages are clickable or have information when hovered.
     
    • Like Like x 1
  10. You did it. Love the plugin so far :D
     
  11. Latest spigot 1.10.2 server, changing light intensity didn't work.
    /addlight lightlevel 1 has the same light level with the /addlight lightlevel 15

    ======UPDATE======
    Another problem. Can't add light when I click the ground, but no error message in the console.( /addlight enable or disable works well.)

    I have to reboot my server to make addlight work again... But after a period of time it didn't work again.

    So how can I help you fix that problem?

    Code (Text):
    Plugins (44): FireworkCreatorPremium, CoreProtect, WorldEdit, OreBroadcast, Essentials, My, PlaceholderAPI, GroupManager, ChestSorter, Toolbox, FastCraftPlus, WorldBorder, Multiverse-Core, ProtocolLib, NoCheatPlus, MoreFish, EssentialsProtect, React, EssentialsChat, EssentialsAntiBuild, TimeIsMoney, AT, Elytra, ShutdownNotice, TreeFeller, Vault, EssentialsSpawn, LightAPI, MarriageMaster, ColorMOTD, NeverLag, 1vs1, BannerMaker, ChestCommands, Residence, AdvancedAchievements, ProtectionLib, Shop, AddLight, JoinMessage, ShinyItems, LockettePro, FurnitureLib, DiceFurniture
     
     
    #54 Laynoooor, Jul 10, 2016
    Last edited: Jul 10, 2016
  12. hi, I introduced this problem when changing the light API.
    The new version 3.1.2 solve this problem.
     
  13. Not working. I tried last versions of both plugins. I also tried these versions: AddLight 3.1.1 with LightAPI 3.1.0 from 1.8.8 to 1.10

    Error in Minecraft Server: An internal error occurred while attempting to perform this command
     
  14. I'm getting an internal error. Why? Using Bukkit 1.10.2 and this [​IMG]

    [20:48:42] [Server thread/INFO]: DatDraggy issued server command: /addlight
    [20:48:42] [Server thread/ERROR]: null
    org.bukkit.command.CommandException: Unhandled exception executing command 'addlight' in plugin AddLight v3.1.1
    at com.github.hexosse.AddLight.framework.pluginapi.PluginCommand.execute(PluginCommand.java:504) ~[?:?]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:140) ~[craftbukkit.jar:git-Bukkit-00359a1]
    at org.bukkit.craftbukkit.v1_10_R1.CraftServer.dispatchCommand(CraftServer.java:625) ~[craftbukkit.jar:git-Bukkit-00359a1]
    at net.minecraft.server.v1_10_R1.PlayerConnection.handleCommand(PlayerConnection.java:1299) [craftbukkit.jar:git-Bukkit-00359a1]
    at net.minecraft.server.v1_10_R1.PlayerConnection.a(PlayerConnection.java:1159) [craftbukkit.jar:git-Bukkit-00359a1]
    at net.minecraft.server.v1_10_R1.PacketPlayInChat.a(SourceFile:37) [craftbukkit.jar:git-Bukkit-00359a1]
    at net.minecraft.server.v1_10_R1.PacketPlayInChat.a(SourceFile:9) [craftbukkit.jar:git-Bukkit-00359a1]
    at net.minecraft.server.v1_10_R1.PlayerConnectionUtils$1.run(SourceFile:13) [craftbukkit.jar:git-Bukkit-00359a1]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.7.0_75]
    at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.7.0_75]
    at net.minecraft.server.v1_10_R1.SystemUtils.a(SourceFile:45) [craftbukkit.jar:git-Bukkit-00359a1]
    at net.minecraft.server.v1_10_R1.MinecraftServer.D(MinecraftServer.java:690) [craftbukkit.jar:git-Bukkit-00359a1]
    at net.minecraft.server.v1_10_R1.DedicatedServer.D(DedicatedServer.java:360) [craftbukkit.jar:git-Bukkit-00359a1]
    at net.minecraft.server.v1_10_R1.MinecraftServer.C(MinecraftServer.java:646) [craftbukkit.jar:git-Bukkit-00359a1]
    at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:550) [craftbukkit.jar:git-Bukkit-00359a1]
    at java.lang.Thread.run(Unknown Source) [?:1.7.0_75]
    Caused by: java.lang.NoClassDefFoundError: Could not initialize class com.github.hexosse.AddLight.framework.pluginapi.message.MessageColor
    at com.github.hexosse.addlight.commands.AlCommands.onCommand(AlCommands.java:65) ~[?:?]
    at com.github.hexosse.AddLight.framework.pluginapi.PluginCommand.execute(PluginCommand.java:500) ~[?:?]
    ... 15 more
     
  15. This
    this is a spigot plugin, not bukkit as i'm using bungge api for all my messages which are clickable with description