Admin commands not working

Discussion in 'BungeeCord Discussion' started by Echen_kraul, Mar 13, 2015.

  1. Im having an issue with bungeecord in which i cant seem to use any admin commands though im sure i have the config set up properly. other than this everything seems to be running fine.

    http://pastebin.com/jsQnY7iR
     
  2. what the console says?
     
  3. which console? the bungee servers console or the spigot servers console?
     
  4. Did you join through the bungeecord ip?
    If not that might be your problem
     
  5. sorry i havent responded sooner. the move to bungee all the servers together was becoming problematic. so we bit the bullet and are in the process of updating everything to 1.8.3 . At this time i can not confirm anything more on the issue and i am hoping that updating will clear up several issues we were having.

    Yes. i was definatly logging in through the ip bungeecord resided on. as soon as i spawned into hub most of the admin commands did not work at all, and gave no errors either in game or in console, they simply did nothing.

    hopefully in the next week ill have everything updated and bungee back up and we will see if it works on 1.8.3
     
  6. glad to hear you sorted everything
     
  7. Update to this issue.... it seems that when setting admin commands in bugeecord it is cap specific which isnt uncommon... however... my name spelled Echen_kraul as i always do is apparently stored by mojangs login server as Echen_Kraul. ive never had an issue with this but i have noticed that when i look up skins on skindex or what not if i type Echen_kraul i get my current skin but if i type Echen_Kraul i get a very old skin i used to use.... apparently the issue was the capital K. i have now sorted the issue out and all admin commands are working as they should.
     
  8. Be sure to add yourself to the admin group in the config.yml through the Bungee Proxy.

    EDIT: Just looked at the PasteBin, Post your bungee server logs.
     
  9. I got it worked out. the post above you describes the issue i was having. seems as though mojang has given me 2 names. one with a capital K and one with lowercase k (which is what ive always used) not sure how that happened but it explains why everytime iveviewed my skin on skindex and other sites it shows my original skin and not the one ive used for almost a year now.
     
  10. TIP!: put \n for to get an new line in your MOTD :) something like
    Code (Text):

    groups:
      Echen_kraul:
      - admin
      RiverSong_XI:
      - admin
      Mexiant:
      - admin
      zerobinary:
      - admin
      annoyedcherry:
      - admin
    disabled_commands:
    - disabledcommandhere
    player_limit: -1
    stats: cbea461e-b916-4e80-a6ba-228e84707230
    permissions:
      default:
      - bungeecord.command.server
      - bungeecord.command.list
      admin:
      - bungeecord.command.alert
      - bungeecord.command.end
      - bungeecord.command.ip
      - bungeecord.command.reload
    listeners:
    - max_players: 500
      fallback_server: skyblock
      host: s50.hosthorde.com:25976
      bind_local_address: false
      ping_passthrough: false
      tab_list: GLOBAL_PING
      default_server: hub
      forced_hosts:
        pvp.md-5.net: pvp
      tab_size: 60
      force_default_server: true
      motd: '&e--&6\={&3SkyBlock&6}\=&e-&6\={&cSurvival&6}\=&e-&6\={&aEconomy&6}\=&e--&6 \nWelcome to &4Greed & Glory'
      query_enabled: true
      query_port: 25976
    timeout: 30000
    connection_throttle: 4000
    servers:
      hub:
        address: s18.hosthorde.com:26067
        restricted: false
        motd: '&e--&6\={&3SkyBlock&6}\=&e-&6\={&cSurvival&6}\=&e-&6\={&aEconomy&6}\=&e--&6 \nWelcome to &4Greed & Glory'
      skyblock:
        address: s16.hosthorde.com:26031
        restricted: false
        motd: '&e--&6\={&3SkyBlock&6}\=&e-&6\={&cSurvival&6}\=&e-&6\={&aEconomy&6}\=&e--&6 \nWelcome to &4Greed & Glory'
    ip_forward: true
    online_mode: true
     
     
  11. found my issue by reading this post