Spigot AetherBank - Customizable Banking Plugin 1.1.4-dev2

Lightweight, real customizable banking plugin. Continuation of EnderBank.

  1. KardasLand submitted a new resource:

    AetherBank - Customizable Banking Plugin - Lightweight, real customizable banking plugin. Continuation of EnderBank.

    Read more about this resource...
     
    • Like Like x 1
    • Friendly Friendly x 1
    • Agree Agree x 1
  2. When you change the item's in the GUI, the colours for their titles does not work. Eg, the Withdraw is red with the custom head. If I change it to a Name Tag, the name shows as &cWithdraw (no colour, literal &c)
     
    • Like Like x 1
  3. Working for a fix, thanks for reporting. Will update today.
     
    • Agree Agree x 1
  4. Having this issue on startup:
    Code (Text):
    [14:32:07 ERROR]: Error occurred while enabling AetherBank v1.0.1 (Is it up to date?)
    java.lang.IllegalArgumentException: [email protected]
            at jdk.internal.reflect.GeneratedMethodAccessor5.invoke(Unknown Source) ~[?:?]
            at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
            at java.lang.reflect.Method.invoke(Method.java:566) ~[?:?]
            at com.kardasland.aetherbank.utils.ClassLoader.addDependency(ClassLoader.java:20) ~[?:?]
            at com.kardasland.aetherbank.AetherBank.loadDatabase(AetherBank.java:72) ~[?:?]
            at com.kardasland.aetherbank.AetherBank.onEnable(AetherBank.java:47) ~[?:?]
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[patched_1.16.5.jar:git-Paper-580]
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:380) ~[patched_1.16.5.jar:git-Paper-580]
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:483) ~[patched_1.16.5.jar:git-Paper-580]
            at org.bukkit.craftbukkit.v1_16_R3.CraftServer.enablePlugin(CraftServer.java:501) ~[patched_1.16.5.jar:git-Paper-580]
            at org.bukkit.craftbukkit.v1_16_R3.CraftServer.enablePlugins(CraftServer.java:415) ~[patched_1.16.5.jar:git-Paper-580]
            at net.minecraft.server.v1_16_R3.MinecraftServer.loadWorld(MinecraftServer.java:580) ~[patched_1.16.5.jar:git-Paper-580]
            at net.minecraft.server.v1_16_R3.DedicatedServer.init(DedicatedServer.java:280) ~[patched_1.16.5.jar:git-Paper-580]
            at net.minecraft.server.v1_16_R3.MinecraftServer.w(MinecraftServer.java:1055) ~[patched_1.16.5.jar:git-Paper-580]
            at net.minecraft.server.v1_16_R3.MinecraftServer.lambda$a$0(MinecraftServer.java:289) ~[patched_1.16.5.jar:git-Paper-580]
            at java.lang.Thread.run(Thread.java:834) [?:?]
    Using Java 11, and Paper.
     
  5. I think this means you need to downgrade to Java 8. A lot of major plugins aren't compiled with Java 11 so it isn't worth the upgrade as of yet :(
     
  6. Bug:
    - Lots of materials can't be used. For example, Kelp, Light Gray Stained Glass Panes, Scute etc.
    - The "-1" for unlimited doesn't work on bank level
    - The interest doesn't seem to be paid (or isn't updated in the GUI) not sure what one.
     
    #9 Swirlio, Apr 9, 2021
    Last edited: Apr 9, 2021
    • Agree Agree x 1
  7. Java 11 is not supported yet. Will support within 2 or 3 major updates.

    Hello, trying to find the issue. I'll give updates on this comment.

    Issue #1: Fixed
    Issue #2: Fixed.
    Issue #3: GUI is not updating in-real time. For example: when you got interest while gui is open, balance won't update in menu, but will in database. Reopening the GUI fixes this issue.
     
    #10 KardasLand, Apr 9, 2021
    Last edited: Apr 9, 2021
  8. All good! Just reporting what I have found for you, no rush :)! Awesome plugin.
     
    • Friendly Friendly x 1
    • Friendly Friendly x 1
  9. This has fixed all the issues except, when putting -1 as the unlimited amount, the maximum deposit I can do is $1.
     
  10. That is strange. I thought i fixed it in testing server lmao. Needs some more testing i guess, will update when I found the problem.
     
  11. I deleted the Level config, Player database etc. when testing to see if they caused the issue but, nope. When i set level 1 to -1 (because i only want one level), in the overview, it says bank balance is -1 and then it lets me deposit 1 to make it 0. after that, the anvil menu tells me i exceeded the limit.
     
  12. Tried with completely default settings, changed default level to limitless. Unfortunately i couldn't be able to reproduce the problem. Are you sure you tried with default? -1 Bank balance is not possible, do you have any error? Or can you check if there is a -1 on playerdata?
     
    • Informative Informative x 1
  13. Sorry for not following up! I had to delete the Level, Playerbase and SQ lite files and then restart the server to get it to work after I updated the plugin on my server! Glad to know, everything works now, without any bugs. Thank you so much.
     
    • Winner Winner x 1
  14. I can confirm there is an issue with the unlimited amount being allowed. I deleted all the files and then it worked for me but another player joined and tried to enter some money in the bank and it says the limited is exceeded. In the overview GUI part, it says their balance is -1. I am not sure what causes this.

    I have narrowed it down to the /reload confirm command. When using this, it doesn't work for any new players that join. /aetherb reload does not fix the issue either. The server needs to be restarted completely before working again. Is it possible to fix this as /reload confirm is a good command when there are multiple people playing etc.

    Thanks
     
  15. Interesting.. Can you confirm there is -1 on playerdata? (with SQLite viewer or something like that.)
    I'll look for root cause, and make reload whole plugin with /aetherb reload for temporary fix.
     
    #19 KardasLand, Apr 11, 2021
    Last edited: Apr 11, 2021
  16. I'm having trouble using this plugin.

    16.04 01:10:20 [Server] INFO Ellendyra issued server command: /BANK
    16.04 01:10:20 [Server] ERROR null
    16.04 01:10:20 [Server] INFO org.bukkit.command.CommandException: Cannot execute command 'bank' in plugin AetherBank v1.0.2 - plugin is disabled.
    16.04 01:10:20 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:37) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:159) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at org.bukkit.craftbukkit.v1_16_R3.CraftServer.dispatchCommand(CraftServer.java:810) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.PlayerConnection.handleCommand(PlayerConnection.java:2168) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.PlayerConnection.c(PlayerConnection.java:1983) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.PlayerConnection.a(PlayerConnection.java:1936) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.PacketPlayInChat.a(PacketPlayInChat.java:50) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.PacketPlayInChat.a(PacketPlayInChat.java:8) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.PlayerConnectionUtils.lambda$ensureMainThread$1(PlayerConnectionUtils.java:35) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.TickTask.run(SourceFile:18) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.IAsyncTaskHandler.executeTask(IAsyncTaskHandler.java:136) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.IAsyncTaskHandlerReentrant.executeTask(SourceFile:23) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.IAsyncTaskHandler.executeNext(IAsyncTaskHandler.java:109) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.MinecraftServer.bb(MinecraftServer.java:1252) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.MinecraftServer.executeNext(MinecraftServer.java:1245) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.IAsyncTaskHandler.awaitTasks(IAsyncTaskHandler.java:119) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.MinecraftServer.sleepForTick(MinecraftServer.java:1206) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.MinecraftServer.w(MinecraftServer.java:1120) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at net.minecraft.server.v1_16_R3.MinecraftServer.lambda$a$0(MinecraftServer.java:289) ~[patched_1.16.5.jar:git-Paper-586]
    16.04 01:10:20 [Server] INFO at java.lang.Thread.run(Thread.java:834) [?:?]