Solved After update to 1.10, Resource packs no longer work, no matter whose.

Discussion in 'Spigot Help' started by Shiro, Jun 21, 2016.

  1. As the title suggests, resource packs "no longer load" for me. as of spigot-mc 1.10 BT 52




    To expand on that a bit further, no matter whose resource pack I give my server.properties a direct link to, after it downloads in-game, nothing happens.

    so, for example, lets say I have that line that says

    Resource-pack=https://www.dropbox.com/s/8in721vv197cadb/Wyrmfire.zip?dl=1

    right? well, I start the server and it tells me the resource-pack needs a sha1 hash, so I just go to an sha1 generator website, plug the dropbox link in, and get the hash, and everything loads up fine, no errors at all.


    ...Except that after logging in and downloading pack in-game, nothing happens at all.



    Now, to make that even stranger, this same problem happens no matter whose resource pack I try this on, even when I make sure it is a direct download-link to the file, no in-between buttons or anything. I put their link infront of the "Resource-pack=", generate the link given a sha1, paste the generated hex into "resource-pack-sha1" in the server.properties aaaaand.... nothing happens upon loading in game.


    Edit for clarity: The resource pack is small, and is only supposed to replace a few sound files, but won't even do that. :(


    Let me know if there are any additional details I could add that could help with this, because boy am I confused.
     
  2. Solved it! in the case that anyone else winds up with this issue: try having a DIRECT LINK resource pack---- without an sha1 hash. i know the server asks for it but for some reason it just works well without the crap