Spigot Alchemy Alchemy 0.2.1.0

Fuse your potions, Potions API

  1. raffa50 submitted a new resource:

    Alchemy - Fuse your potions

    Read more about this resource...
     
  2. great idea before i start using this here are a few suggestions:
    Allow us to brew it together (1 potion top 3 bottom like the normal brewing stand)
    Change the color of the potion/arrow based on the colors of the other one. (combine blue blue red for a slightly purple one for example)
    base the time on the time in the potions.
    mabe a couldron that we can pour potions into and then takeout it combined instead of using the brewingstand/crafting table
     
  3. Hi, your plugin seem to be realy nice but simly don't start on my server, he dosn't have create any files for an config and nothings work about the plugin :/ could you help me ?
     
  4. raffa50 updated Alchemy with a new update entry:

    Alchemy v2

    Read the rest of this update entry...
     
  5. [12:50:22 ERROR]: Could not load 'plugins\Alchemy.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: aldrigos/mc/alchemy/AlchemyPlugin has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:138) ~[Paper-latest.jar:git-Paper-103]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:352) ~[Paper-latest.jar:git-Paper-103]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:272) ~[Paper-latest.jar:git-Paper-103]
    at org.bukkit.craftbukkit.v1_15_R1.CraftServer.loadPlugins(CraftServer.java:358) ~[Paper-latest.jar:git-Paper-103]
    at net.minecraft.server.v1_15_R1.DedicatedServer.init(DedicatedServer.java:234) ~[Paper-latest.jar:git-Paper-103]
    at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:885) ~[Paper-latest.jar:git-Paper-103]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_241]
    Caused by: java.lang.UnsupportedClassVersionError: aldrigos/mc/alchemy/AlchemyPlugin has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_241]
    at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.8.0_241]
    at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.8.0_241]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:167) ~[Paper-latest.jar:git-Paper-103]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:100) ~[Paper-latest.jar:git-Paper-103]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_241]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_241]
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_241]
    at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_241]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:68) ~[Paper-latest.jar:git-Paper-103]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:134) ~[Paper-latest.jar:git-Paper-103]
    ... 6 more
     
  6. You need Java11+ https://www.oracle.com/java/technologies/javase/jdk11-archive-downloads.html
    you can also use latest Java13 (remember to uninstall previous Java versions, Java is retrocompatible)
     
  7. Please, add support for 1.12.2 please!! I didn't find same plugin anywhere((((