1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Rejected All Entities are Invisible.

Discussion in 'Bugs & Feature Requests' started by TheGreatScratchy, Jul 17, 2013.

  1. Hello everyone,
    I have a bug, or error, or something.
    I actually have no clue what it is, but I need help.
    Anyways I stopped the server to configure some plugins ( I did stop it properly)
    but when I loaded it back up Me, and another player couldn't see each other. We then noticed
    we couldn't see any entities. I actually have no idea what happened, and I need help.
    Right now I THINK it might be something with the spigot configuration, but I'm not sure.
    My host said he hasn't seen anything like this happen before, and I just need to get my server up and running. Thanks for your help.

    Here is my configuration http://pastebin.com/FXw1254v
     
  2. PhanaticD

    Patron

    "view-distance: 1" change that to 4+
     
    • Like Like x 1
    • Agree Agree x 1
    • Useful Useful x 1
  3. It didn't work I still don't have any entities showing. I throw stuff on the ground but I can't see them, nor can I see paintings or item frames.
     
  4. PhanaticD

    Patron

    can u repost your new config
     
  5. Try a new world maybe. Disable the old one by renaming it and let the server produce a new one. Also a list of plugins and which build you're using would be nice.

    EDIT: saw your log just now try disabling plugins mostly the ones that have to do with world management.
     
  6. ;_;


    Spigot is not a plugin..............................
     
    • Like Like x 1
    • Winner Winner x 1
  7. I am well aware of that...
     
  8. Dmck2b

    Services Staff

    So why are you trying to load it as one?

    1. 2013-07-16 20:44:33 [SEVERE] Could not load 'plugins\spigot.jar' in folder 'plugins'
     
    • Agree Agree x 1
    • Funny Funny x 1
    • Winner Winner x 1
  9. Okay so I Unloaded:
    Essentials
    Worldguard
    Worldedit
    Multiverse-Core (And Portals and Multi-Inv)
    Modifyworld
    PermissionsEx

    Unfortunately I still have the exact same problem! D:
    Now I am almost certain that either spigot.jar is corrupt or I messed something up in the config.

    List of plugins:
    Worldedit
    NoCheatPlus
    Skript
    MOTDManager
    Vault
    Backpack
    PlayerHeads
    CombatTag
    HealthBar
    uSkyBlock
    SilkSpawners
    Iconomy
    CoreProtect
    AntiXRay
    WhatIsIt
    PVPTitles
    Clearlag
    Autocast
    Votifier
    MCmmo
    floAuction
    Citizens
    SimpleVoteListener
    ChatManager
    ChatProtectionPlus
    Essentials
    Enjin Minecraft Plugin
    RedeemMcMmo
    PlugMan

    That took a while, but I need to fix it D:
     
  10. @Dmk
    I guess I accidentally put spigot in the plugins folder when I was updating, but that's not the problem because I updated a few days ago and it just messed up a hours ago.
     
  11. Dmck2b

    Services Staff

    Have you tried running stock spigot? No plugins running at all? Unloading only a few isn't really a justification of Spigot being the issue.
     
  12. Yea we were actually about to do that, and add each plugin 1 by 1. When it breaks we'll see.
     
  13. Okay guys we fixed it. Turns out it was in the server properties *FUCKING FACEPALM THROUGH SPACE*
    I feel so retarded like seriously.
    Sorry for blaming spigot.
    Thank you all for your help :D




    Im so mad at myself for being so stupid....
    *QUAD FACEPALM**
     
  14. [​IMG]
    Way ahead of you.
     
  15. md_5

    Administrator Developer

    View distance of < 3 is not supported. It may work, it may not, I know for a fact that '1' causes issues such as the invisible entities.