Ancient Gates Error

Discussion in 'Spigot Plugin Help' started by termanator1128, Jun 4, 2015.

  1. Hi when I load my server and it enables the plugin it gives me this error

    3:36:22 PM [ERROR] Error occurred while enabling AncientGates v1.8.0 (Is it up to date?)
    3:36:22 PM org.bukkit.craftbukkit.libs.com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 1
    3:36:22 PM at org.bukkit.craftbukkit.libs.com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:176) ~[spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at org.bukkit.craftbukkit.libs.com.google.gson.Gson.fromJson(Gson.java:803) ~[spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at org.bukkit.craftbukkit.libs.com.google.gson.Gson.fromJson(Gson.java:768) ~[spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at org.bukkit.craftbukkit.libs.com.google.gson.Gson.fromJson(Gson.java:717) ~[spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at org.bukkit.craftbukkit.libs.com.google.gson.Gson.fromJson(Gson.java:689) ~[spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at org.mcteam.ancientgates.Conf.load(Conf.java:103) ~[?:?]
    3:36:22 PM at org.mcteam.ancientgates.Plugin.onEnable(Plugin.java:152) ~[?:?]
    3:36:22 PM at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:335) [spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugin(CraftServer.java:356) [spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at org.bukkit.craftbukkit.v1_8_R1.CraftServer.enablePlugins(CraftServer.java:316) [spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at net.minecraft.server.v1_8_R1.MinecraftServer.q(MinecraftServer.java:402) [spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at net.minecraft.server.v1_8_R1.MinecraftServer.k(MinecraftServer.java:370) [spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at net.minecraft.server.v1_8_R1.MinecraftServer.a(MinecraftServer.java:325) [spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:211) [spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at java.lang.Thread.run(Unknown Source) [?:1.8.0_45]
    3:36:22 PM Caused by: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 1 column 1
    3:36:22 PM at org.bukkit.craftbukkit.libs.com.google.gson.stream.JsonReader.beginObject(JsonReader.java:374) ~[spigot-1.8.jar:git-Spigot-550ebac-7019900]
    3:36:22 PM at org.bukkit.craftbukkit.libs.com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:165) ~[spigot-1.8.jar:git-Spigot-550ebac-7019900]
     
  2. AngelRani

    Supporter

    AncientGates does not work for 1.8.x. I used to have AncientGates myself, but I switched to BungeeSuitePortals because AncientGates doesn't work with the new Spigot updates.
     
  3. It's working for me o_O ..
     
  4. AngelRani

    Supporter

    What Spigot version do you have?
     
  5. I don't remember the command for infos ? Can you tell me please :p ?
     
  6. AngelRani

    Supporter

  7. I thought I was running Spigot (But my server supports Spigot plugins) o_O

    [​IMG]
     
  8. AngelRani

    Supporter

    That is because Spigot IS CraftBukkit. Spigot is just a slightly modified version of Bukkit. Plus you have 1.8. AncientGates will work with 1.8, but not wih updates 1.8.1 and above.
     
    #8 AngelRani, Jun 4, 2015
    Last edited: Jun 4, 2015