Spigot Anti-VPN 4.9.31

Get the best; save money on overpriced plugins and block VPN users!

  1. Hi there, I suggest on making the command /avpn test <player name> or /avpn check <player name> instead of IP, because it will make players' ip more private towards the staff members, and even the owner :)
     
  2. Not a bad suggestion, thanks!
     
  3. @egg82 hey, i just restarted the server, i did not update anything, not the paper version neither java stuff or other things on the server. The oly thing i updated is "Protection Stones" plugin. Now Anti VPN is taking a lot of time to load. Looks like it is stuck here:

    Code (Text):
    [09:27:38 INFO]: [AntiVPN] Loading AntiVPN v4.9.31
    [09:27:38 INFO]: [Anti-VPN] Checking version of ACF
    [09:27:38 INFO]: [Anti-VPN] Checking version of SQLite
    [09:27:38 INFO]: [Anti-VPN] Checking version of MySQL
     
    Minutes are passing the server won't event start.

    The plugin always worked fine since august or so. What happened?

    Paper 255

    Edit

    Ok, after five minutes or so it just proceeded, and i got this. Then the server kept starting up...

    Code (Text):
    [09:30:41 WARN]: SLF4J: Class path contains multiple SLF4J bindings.
    [09:30:41 WARN]: SLF4J: Found binding in [jar:file:/home/ubuntu/Server/plugins/antivpn-bukkit-4.9.31.jar!/org/slf4j/impl/StaticLoggerBinder.class]
    [09:30:41 WARN]: SLF4J: Found binding in [jar:file:/home/ubuntu/Server/cache/patched_1.14.4.jar!/org/slf4j/impl/StaticLoggerBinder.class]
    [09:30:41 WARN]: SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
    [09:30:41 WARN]: SLF4J: Actual binding is of type [org.slf4j.impl.BukkitLoggerFactory]
     
    Edit

    So i decided to restart it again to see if it was fixed but nope.. the server is stuck again

    Edit

    Tried to remove all the files from the plugin folder (not config.yml) and let them regenerate.. this is taking way too long that what it used to take on first startup.

    What happened to the plugin?

    Edit

    After 15 minutes it is still downloading google guava.. the plugin is officially broken, and it did all by itself :(

    Edit

    I filed an issue on github, more updated reports there
     
    #103 Hosom, Nov 9, 2019
    Last edited: Nov 9, 2019
  4. @Hosom
    I have the same exact issue. We really need this fixed :)
     
  5. Ugh.. at least i am not the only one! Something happened to the plugin today, but i can't really understand.

    Follow this issue on github:
    https://github.com/egg82/AntiVPN/issues/35
     
  6. I'm having this as well.
     
  7. Same issue as well:

    Code (Text):
    [17:27:05] [Server thread/INFO]: [AntiVPN] Loading AntiVPN v4.9.31
    [17:27:05] [Server thread/INFO]: [Anti-VPN] Checking version of ACF
    [17:27:05] [Server thread/INFO]: [Anti-VPN] Checking version of SQLite
    [17:27:05] [Server thread/INFO]: [Anti-VPN] Checking version of MySQL
     
  8. Is it possible to disable this plugin if the whitelist is enabled? Wasting API limits for no reason when no one can join anyway.
     
    • Like Like x 1
  9. That's a good point... maybe while server is under maintenance.

    Tho, I never reached api limits so far. I think that the plugin uses a cache system to avoid sending too many requests