1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Solved Anti Xray (Engine 2) is not working as expected

Discussion in 'Bugs & Feature Requests' started by Puremin0rez, Jul 26, 2013.

  1. Puremin0rez

    Moderator

    I'm not sure how long this has been going on, but tehrainbowguy informed me about this earlier today.

    It appears that Engine Mode 2 is no longer obfuscating all of the stone in the world, instead, it's doing just the ores. This basically makes Anti Xray worthless, as people can still see where all the ores are, just not what ore they are until they go to it.

    Here's some screenshots to get a better idea of what I mean

    [​IMG]

    [​IMG]

    These were taken using //chunk and //cut.
     
  2. PhanaticD

    Patron

    Its because they removed stone and dirt and such from the default xray list in spigot.yml No idea why..
     
  3. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    Maybe performance issues?
    readd them and it should be fine. I will try it later
     
    • Funny Funny x 1
  4. md_5

    Administrator Developer

    Oooooooooooooooooooooooooooooooh, I see.
     
  5. Puremin0rez

    Moderator

    Totally forgot about that commit!

    It seems as if it was done to "work around" a block lag glitch. However, a commit or so after that one it appears md_5 made a proper fix for the underlying issue, leading me to believe it's safe to add stone back.

    Edit: ninja'd by md_5
     
  6. md_5

    Administrator Developer

    Added new replacements section to config.
    Solved.