Premium AntiAura - (Premium Anti-Cheat plugin) [Paid]

Discussion in 'Resource Discussion' started by joehot200, Oct 7, 2014.

  1. Hey, it's still doing the disappearing entity bug.
    I also noticed that no one can use Elytras without getting pulled down. Any way we can work around this? Thanks
     
  2. Code (Text):
    [AntiAura]: Enabling AntiAura v11.86-1
    Using pre-1.14 ray tracing....
    ERROR 16:55:10
    Error occurred while enabling AntiAura v11.86-1 (Is it up to date?)
    Console 16:55:10
    java.lang.NoClassDefFoundError: org/bukkit/block/data/BlockData
    at java.lang.Class.getDeclaredMethods0(Native Method) ~[?:1.8.0_242]
    at java.lang.Class.privateGetDeclaredMethods(Class.java:2701) ~[?:1.8.0_242]
    at java.lang.Class.privateGetMethodRecursive(Class.java:3048) ~[?:1.8.0_242]
    at java.lang.Class.getMethod0(Class.java:3018) ~[?:1.8.0_242]
    at java.lang.Class.getMethod(Class.java:1784) ~[?:1.8.0_242]
    at joehot200.S.a(S.java:994) ~[?:?]
    at joehot200.AntiAura.onEnable(AntiAura.java:34) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[patched_1.12.2.jar:git-Paper-1618]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:316) ~[patched_1.12.2.jar:git-Paper-1618]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) ~[patched_1.12.2.jar:git-Paper-1618]
    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:395) ~[patched_1.12.2.jar:git-Paper-1618]
    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:344) ~[patched_1.12.2.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:442) ~[patched_1.12.2.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:403) ~[patched_1.12.2.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:341) ~[patched_1.12.2.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:289) ~[patched_1.12.2.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:616) ~[patched_1.12.2.jar:git-Paper-1618]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_242]
    Caused by: java.lang.ClassNotFoundException: org.bukkit.block.data.BlockData
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:109) ~[patched_1.12.2.jar:git-Paper-1618]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:104) ~[patched_1.12.2.jar:git-Paper-1618]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:419) ~[?:1.8.0_242]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:352) ~[?:1.8.0_242]
    ... 18 more
    INFO 16:55:10
    [AntiAura]: Disabling AntiAura v11.86-1
    Edit: same problem with the dev version on version history
     
  3. It seems like opening (custom) GUIs is causing an exception from AntiAura in 1.12.2. This is taken from the console, I can't see anything wrong in-game though

    Also "[]" is being spammed a few times in the console whenever a Citizens NPC is hit. I don't know the source but I'd like to ask if AntiAura is printing that somehow.

    Code (Text):
    java.lang.NoClassDefFoundError: org/bukkit/inventory/BlockInventoryHolder
    at joehot200.z.a(z.java:77) ~[?:?]
    at com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventExecutor221.execute(Unknown Source) ~[?:?]
    at org.bukkit.plugin.EventExecutor$2.execute(EventExecutor.java:70) ~[server.jar:git-Paper-1618]
    at co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:78) ~[server.jar:git-Paper-1618]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[server.jar:git-Paper-1618]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:513) ~[server.jar:git-Paper-1618]
    at org.bukkit.craftbukkit.v1_12_R1.event.CraftEventFactory.callInventoryOpenEvent(CraftEventFactory.java:825) ~[server.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.EntityPlayer.openContainer(EntityPlayer.java:853) ~[server.jar:git-Paper-1618]
    at org.bukkit.craftbukkit.v1_12_R1.entity.CraftHumanEntity.openInventory(CraftHumanEntity.java:195) ~[server.jar:git-Paper-1618]
    at me.bimmr.bimmcore.menus.inventory.MenuGUI.open(MenuGUI.java:200) ~[?:?]
    -snip-$3.run(-snip-) ~[?:?]
    at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftTask.run(CraftTask.java:64) ~[server.jar:git-Paper-1618]
    at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:423) ~[server.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.D(MinecraftServer.java:840) ~[server.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:423) ~[server.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:774) ~[server.jar:git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:666) ~[server.jar:git-Paper-1618]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_265]
     
    • Useful Useful x 1
  4. joehot200

    Supporter

    I'm hoping that this was fixed on 11.87, am I correct? Nevermind, I think this is fixed in a dev build.

    The errors are both totally harmless, but I'll try and have them fixed for the next update.

    I would suspect that Citizens could be an AntiAura thing - are you able to get me that error too? In the last update I believe I solved the errors regarding Citizens NPCs, but perhaps this is a different issue.

    Thanks.
     
    #8304 joehot200, Aug 18, 2020
    Last edited: Aug 18, 2020
  5. No errors with the citizens thing, it's just the console printing "[]" around 5 times every time the citizen is hit. My gun plugin registers all hits as normal hits (like punching/melee) from a distance and I have all combat checks turned off in AntiAura as a result. Players shoot invincible NPCs as shooting range, and I have a plugin that does hit detection but I have double checked and the relevant parts of my code don't print/log anything. It's either Citizens or AntiAura or one of the Citizens addons

    I've also noticed that occasionally an empty line of chat message is printed when I shoot mobs (unrelated to the shooting range mentioned above), I think it's unlikely to be related to AntiAura but I'm just putting that there just in case you know what's going on
     
  6. joehot200

    Supporter

    joehot200 updated AntiAura - (Premium Anti-Cheat plugin) with a new update entry:

    Improved CPU usage, detection improvements & new ray modes.

    Read the rest of this update entry...
     
  7. Hi,

    The plugin work pretty well, I have just little issue with "Dolphin's Grace" effect which is considered as cheating by the plugin,

    I'm using the latest build of both the plugin and paperspigot (#136) on minecraft 1.16.1,
     
    • Informative Informative x 1
  8. joehot200

    Supporter

  9. Server CPU is getting crushed with this plugin enabled. I have run the timings report, paste command isn't working for me so no nice URL for this, but attaching the file. If anyone can take a look it would be appreciated.

    **Update - did some further configuration changes and the CPU is much lower now. Disabled some of the checks that my server doesn't use.
     

    Attached Files:

    #8309 Gregpeg528, Aug 27, 2020
    Last edited: Aug 28, 2020
  10. Hello @joehot200 !

    I reinstalled AntiAura days ago and players can't use elytras because chunks don't load. Here is a video made by one of my moderators:

    I have disabled Flight and Elytras checks, but the problem is the same.
    For the moment I am obliged to remove AntiAura: /

    There is still the multiple packet issue with Protocollib (TileESP), yet it has been updated to version 1.16.2 and the developer has closed the issue that talks about it:
    https://github.com/dmulloy2/ProtocolLib/issues/941

    So AntiAura always deactivates the TileESP check.
    I point this out because I don't know if this is normal.

    Server version: 1.16.2
    Antiaura: 11.87-2
     
    • Like Like x 1
  11. joehot200

    Supporter

    Hi Chevels

    As far as I can tell, the problem is coming from the fact that chunks are not loading, and not any of AntiAura's checks. AntiAura does process chunks when they are loaded, which could cause a problem. I would recommend '/aconfiga Map MaxChunksPerInterval 1' to reduce the amount of processing speed.

    Could you also confirm if this Elytra issue occurs without AntiAura installed? As I mentioned before, the issue appears to occur due to chunks not loading, which could have multiple causes.

    ProtocolLib's 1.16.2 update has required me to make code changes to TileESP, which I actually completed a while ago but there are other features that require testing before releasing the next update.

    Regards
    Joe
     
    • Like Like x 1
  12. Hi Joehot200,

    We have done several trials with and without AntiAura, and I can confirm for sure that this issue only occurs when Antiaura is installed.
    Earlier we did a test without AntiAura and the video below shows that the problem does not appear:

    Sorry for the audio, we didn't know it recorded sound too^^ :giggle:

    In fact, when this issue occurs, I have the impression that from the moment the player uses his elytras, the client can only navigate in the chunks that were already loaded and no longer has the right to load others.
    I would like to point out that the server is very efficient and that at this time it was at 20TPS. The player had a 12ms ping during the test.

    I will test this as soon as possible. Thanks for the advice.

    So everything's OK !

    Good luck with the development and thank you for your work :)
     
  13. joehot200

    Supporter

    joehot200 updated AntiAura - (Premium Anti-Cheat plugin) with a new update entry:

    Killaura improvements - Geyser compatibility - Map improvements

    Read the rest of this update entry...
     
  14. enterih

    Patron

    how does this plugin handle attributes like movementspeed on boots, attackspeed etc.?
     
  15. joehot200

    Supporter

  16. joehot200

    Supporter

  17. Hey your plugin is attacking players in my server for no reason it is literally hitting them and causing them to take damage it's annoying please reach out to me when you can thanks! i paid for this plugin and i didn't expect it to be this broken
     
  18. In 11.88, AntiAura started accounting for movement speed attributes, if that answers your question :)
     
  19. joehot200

    Supporter

    joehot200 updated AntiAura - (Premium Anti-Cheat plugin) with a new update entry:

    Improvements to the movement checks

    Read the rest of this update entry...
     
  20. joehot200

    Supporter

    Sounds like you were getting false positives from the Speed check. I'd recommend trying out the latest update, as it heavily focuses on improving the Speed check to reduce false positives. If you're still encountering issues, please contact me with more detail via Discord or PM. Cheers!