Spigot [API] ReflectionHelper 1.14.8-SNAPSHOT

Library to easily access Classes, Fields & Methods using reflection

  1. inventivetalent submitted a new resource:

    [API] ReflectionHelper - Library to easily access Classes, Fields & Methods using reflection

    Read more about this resource...
     
  2. Doesn't seem to work for me...
    Downloaded from http://dl.inventivetalent.org/plugin/?plugin=ReflectionHelper&version=1.3.0
    Code (Text):

    [18:43:57 ERROR]: Could not load 'plugins/ReflectionHelper_v1.3.0.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
        at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:154) ~[spigot.jar:git-Spigot-104c8c8-00d3334]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [spigot.jar:git-Spigot-104c8c8-00d3334]
        at org.bukkit.craftbukkit.v1_9_R1.CraftServer.loadPlugins(CraftServer.java:296) [spigot.jar:git-Spigot-104c8c8-00d3334]
        at net.minecraft.server.v1_9_R1.DedicatedServer.init(DedicatedServer.java:201) [spigot.jar:git-Spigot-104c8c8-00d3334]
        at net.minecraft.server.v1_9_R1.MinecraftServer.run(MinecraftServer.java:527) [spigot.jar:git-Spigot-104c8c8-00d3334]
        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_40]
    Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml

        ... 6 more
     
    Is this my fault?
     
  3. It's not a plugin, you'll have to compile it with your own plugin.