Spigot [API] SpigotUpdater 1.0.1

Update checker for spigot resources

  1. inventivetalent submitted a new resource:

    [API] SpigotUpdater - Update checker for spigot resources

    Read more about this resource...
     
  2. Keep getting this error:
    Code (Text):
    Invalid response received.
    [Thread-8/WARN]: [LockedItems] [Updater] Either the author of this plugin has configured the updater wrong, or the API is experiencing some issues.
    Is it just me who is having this error?
     
  3. joehot200

    Supporter

    Does this work for Premium plugins?
     
  4. Probably not your problem. My online API has some trouble with Spigot's CloudFlare protection. I'm currently working on the backend to make it a bit more reliable.

    Yes.
     
  5. BTW, it was working before
     
  6. I Get This Error, Please Help, I Dont Know How To Use This >.<

    Error:
    [22:09:07 INFO]: [PlayerMention] [AutoUpdater] Searching for updates.
    [22:09:07 INFO]: CONSOLE: Reload complete.
    [22:09:07 WARN]: [PlayerMention] [AutoUpdater] API connection returned response
    code 403
    [22:09:07 WARN]: java.io.IOException: Server returned HTTP response code: 403 fo
    r URL: http://www.spigotmc.org/resources/playermention.8963
    [22:09:07 WARN]: at sun.net.www.protocol.http.HttpURLConnection.getInputS
    tream0(Unknown Source)
    [22:09:07 WARN]: at sun.net.www.protocol.http.HttpURLConnection.getInputS
    tream(Unknown Source)
    [22:09:07 WARN]: at me.hypexmon5ter.pm.SpigotUpdater.run(SpigotUpdater.ja
    va:143)
     
  7. Unfortunately, spigot's cloudflare protection sometimes blocks my website from accessing spigotmc.org, so it can't get the information about the plugin.
     
  8. @HYPExMon5ter
    Please use the discussion to report problems before reviewing.
    Which resource did you try to check for updates?
     
    • Agree Agree x 1
  9. No. From your browser.
     
  10. yea i can
     
  11. What is the code you used to create your updater?
     
  12. you fixed the 403 error in the update? (i haven't tried the new update)