Are You Rate Limited? Skins, Skulls etc no longer displaying.

Discussion in 'Server & Community Management' started by Chalkie, Jun 17, 2017.

  1. Within the last week mine along with multiple other people have lost the ability to do profile lookups via Mojangs API.

    I first noticed the issue about two days ago when a piece of software (Skin Restorer) wasn’t able to do profile look ups due a 429 Too Many Requests error.
    The next day, I noticed it still wasn’t fixed and though it may have been an issue with the software, but it wasn’t the only thing not working.
    I had also lost the ability to display new skins on NPC’s (Citizens) and to display skins on skulls (using essentials /skull <player>).

    I decided to turn off everything in the server, the only thing left running was FTP, SSH and the OS. There was nothing trying to resolve profiles from Mojang. After an hour and half I decided to try do a profile lookup from putty (curl https://api.mojang.com/users/profiles/minecraft/Chalkie) and it still stated I was rate limited.
    As a side note, I have the same setup on my local test server and profile lookup work correctly. So I don’t believe it’s a problem with the plugins, spigot or bungeecord.

    I have been able to ‘fix’ this for the Skin Restorer software by using a third party API instead of api.mojang.com for profile lookups but it doesn’t fix it for anything else.

    I am still able to access other parts of Mojang.
    Example: Citizen NPC's created prior to this issue that already have a their UUID, Skin Signatures and Textures resolved work fine and my Chest GUI that displays head textures via textures.minecraft.net also works.
    I am also able to still use curl sessionserver.mojang.com/session/minecraft/profile/2b5bf511afc74ee395d64ea4ce34bbe0.

    I am not the only one running into this issue, there are a magnitude of reports in the Skin Restorer discord (however most seem to think the issue is just with SR atm) and some have started to pop up on the Citizens Issues.

    For anyone experience this issue are you;

    • Hosting via OVH or SYS or your dedicated server is on either of those two. (Is it in NA?)
    • Able to replicate the issue using curl https://api.mojang.com/users/profiles/minecraft/notch via Putty.
    • What OS are you using.
    • Tried generating a new (a name you haven't used before) skull with the /skull <player> command and it not worked.

    Edit: More information has been posted about this on /r/admincraft thanks to RedZephon.

    Edit:2 The almighty Dinnerbones has graced these forums with his presence. The issue was a mistake and has been fixed.
     
    #1 Chalkie, Jun 17, 2017
    Last edited: Jun 20, 2017
    • Funny Funny x 1
    • Informative Informative x 1
  2. I have the same problem, also OVH (EU).
    Thought it was SR too, guess not.
     
    • Informative Informative x 1
  3. TowelieDOH

    Supporter

    I have the same problem too, OVH (CA)
    Centos 7.2 x64
     
    • Informative Informative x 1
  4. My guess is that something recently changed with their hosting and they can't properly relay the API information correctly until an update (maybe?) has been pushed to fix it.
     
    • Informative Informative x 1
  5. TowelieDOH

    Supporter

    My workaround for this is:

    - Have a linux server outside of OVH or Linude
    - From the Minecraft server, create a ssh tunnel to that server using ssh -D <proxy_port> <user>@<host>
    - After the tunnel has been created (after you have logged in), add the following to your server's startup parameters and restart:
    -DsocksProxyHost=127.0.0.1 -DsocksProxyPort=<proxy_port> -DsocksProxyVersion=5

    This effectively routes java's traffic through the SSH tunnel. Tested and working.
     
  6. FHR

    FHR

    Seems like not all OVH ranges are blocked. I have 3 OVH IPs:

    * 167.114.230.xxx - TooManyRequestsException
    * 176.31.26.xxx - OK
    * 94.23.173.xxx - OK

    Minecraft was only ever hosted on 176.31.26.xxx.

    If anyone wants a way to quickly test this:
    Code (Text):
    curl --header "Content-Type: application/json" --data "[\"FHR\"]" https://api.mojang.com/profiles/minecraft
    If you have multiple IPs on your server and want to test them, you can specify a source IP like this:
    Code (Text):
    curl --interface 1.2.3.4 --header "Content-Type: application/json" --data "[\"FHR\"]" https://api.mojang.com/profiles/minecraft
     
    • Informative Informative x 1
  7. I got a similar problem, 429 error when running Spigot 1.12 with hosting service: ServerMiner

    When running Vanilla on serverminer it works fine however.

    Anyone run into something similar? Perhaps a spigot issue?
     
  8. Dinnerbone

    Mojang

    Hello friends!

    Sorry about all the trouble. It wasn't intentional that these specific routes were blocked, it was a side effect of an emergency measure elsewhere and we didn't realize it would impact all of the public API. The original issue is cleared up now so you should see this problem go away shortly.

    <3
     
    • Like x 12
    • Winner x 8
    • Friendly x 3
    • Informative x 2
    • Creative x 2
    • Agree x 1
    • Funny x 1
    • Useful x 1
    • Optimistic x 1
  9. Ok, excellent. Thank you.
     
    • Agree Agree x 1
  10. Thanks for info ǝuoqɹǝuuᴉp!
     
  11. great glad to know that this was not intentional :D
     
    • Agree Agree x 1
  12. Thanks for the info. I was getting worried :)
     
    • Friendly Friendly x 1
  13. Legoman99573

    Supporter

    GG and welcome to the spigot community :)
     
    • Like Like x 1
  14. I have the same problem too, OVH (CA)
    Debian.

    Thank god Dinnerbone replied that this wasn't intentional, I was getting out my conspiracy stick for this push to try and slowly kill the Java community.
     
  15. Well, kinda sounded like the problem was fixed, but I'm still having the same issue with the 429 error :c

    Seems its the same for you too
     
  16. Same, Im getting
    Code (Text):
    {"error":"TooManyRequestsException","errorMessage":"The client has sent too many requests within a certain amount of time"}
    When I curl it.
     
  17. Dinnerbone

    Mojang

    It's possible that if you already made a bunch of requests that it gave you a longer limit. You may need to hold off for 24 hours. Sorry about that :(
     
    • Informative Informative x 4
    • Winner Winner x 3
  18. x-x 24rs?

    Like from making any requests? That'd imply shutting the server down no? :eek:
     
  19. How many requests are you doing...? I'm using the MojangAPI and working just fine.
     
  20. Like none? It's just me alone on a server xD
     
    • Agree Agree x 2