Spigot AreaShop 2.6.0

A plugin that gives players the option to rent or buy regions from WorldGuard

  1. I get spammed with using paper

    [17:44:06 ERROR]: Could not pass event BlockPhysicsEvent to AreaShop v2.6.0
    java.lang.ClassCastException: null
     
  2. I need some help. AS wont work!

    [30-Jan-2020 22:30:08] [GriefPrevention] RealXypher placed a sign @ pshop: x-6, z-1;[asrent];shop1;1 week;3000

    [30-Jan-2020 22:30:08] Could not pass event SignChangeEvent to AreaShop v2.6.0

    [30-Jan-2020 22:30:08] java.lang.ClassCastException: org.bukkit.material.MaterialData cannot be cast to org.bukkit.material.Sign

    [30-Jan-2020 22:30:08] at me.wiefferink.areashop.features.signs.SignsFeature.onSignChange(SignsFeature.java:280) ~[?:?]

    [30-Jan-2020 22:30:08] at com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventExecutor1447.execute(Unknown Source) ~[?:?]

    [30-Jan-2020 22:30:08] at org.bukkit.plugin.EventExecutor.lambda$create$1(EventExecutor.java:69) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:80) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:70) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:545) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.PlayerConnection.a(PlayerConnection.java:2581) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.PacketPlayInUpdateSign.a(SourceFile:44) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.PacketPlayInUpdateSign.a(SourceFile:10) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.PlayerConnectionUtils.lambda$ensureMainThread$0(PlayerConnectionUtils.java:23) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.TickTask.run(SourceFile:18) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.executeTask(IAsyncTaskHandler.java:136) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.IAsyncTaskHandlerReentrant.executeTask(SourceFile:23) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.executeNext(IAsyncTaskHandler.java:109) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.MinecraftServer.ba(MinecraftServer.java:1038) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.MinecraftServer.executeNext(MinecraftServer.java:1031) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.IAsyncTaskHandler.awaitTasks(IAsyncTaskHandler.java:119) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.MinecraftServer.sleepForTick(MinecraftServer.java:1015) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:938) ~[patched_1.15.2.jar:git-Paper-79]

    [30-Jan-2020 22:30:08] at java.lang.Thread.run(Thread.java:748) [?:1.8.0_131]
     
  3. Hi @NLThijs48,
    Is it possible to use your plugin in 1.15?
    Moreover, is it possible to use a Web Interface like an e-real eastate agency with local map or something?
     
  4. Yes it is if u use the latest dev build, everything works fine (got it on a 1.15.2 server myself)
     
  5. Hi,
    Well, after several days of testing, several errors spasm my web console. So I guess this plugin is not supposed to work properly in 1.15.
     
  6. Really wonder why that happens because I've had no problems (or errors in the console) at all and it's been on 1.15 for a few weeks now.
     
  7.  
  8. Can this be updated to 1.15 so I can use it on my server. PLEASE
     
  9. Very odd that it does not work for you guys, maybe another plugin that's causing trouble? I don't have any issues with the latest dev build.
     
  10. I set up areashop, but now when I go to rent it says it's an unregistered region. The signs are linked and don't do anything. Tried commands in the region, specifying the correct region and that's what's pops up. Also, nothing in console.
     
  11. you need to update your plugin to 1.15.2 and fix it.
     
  12. Hey, I think we have a permission issue.

    We use the latest version on Spigot 1.13.2.
    When an OP or a player with areashop.* tries to do '/as tp xy' he gets the message that he has no permissions to do that. We even tried to give the permission 'areashop.teleportall', but its still not working.
    Next we tried to set a new teleport point, but we also have no permission to do that.

    No errors in the console.
    Do you have any idea?
     
  13. Hello, I'm trying to set a region for rent using the following: /as add rent [regionName] 7d 5500

    However, every time I hit enter, it prompts me that the region can be rented for $1,000 a day which I do not want.
    Is there something I'm not doing correctly?

    Also while I'm here, Say I have a building and it's a hotel. If I rent out the building for one week, is it possible to allow the player who rented the whole building to earn the coins from renting out rooms created with smaller sub regions inside the building?
     
  14. I am using AreaShop version 2.6.0#296 and I just upgraded my server from 1.14.4 to 1.15.2 and now I have a player that can only place in their shop but they cannot break anything. The shop was set up before the upgrade. I am using the same version of AS because the newer versions 297, 298 and 299 are marked as no changes and 300 is marked as not compiling correctly. I am also using Paper-146
     
  15. Does this plugin works good with preciousstones? i ask because if i use the precioustones signs as [RENT] or [BUY] rent dont give me problem, buy there's a trouble when i use [BUY] because i also have a AdminShop with Essentials using [BUY] sign and it makes a conflict and [BUY] For Precioustones doesn't work