Spigot ASkyBlock V3.0.9.4

A skyblock plugin!

    • Max team members - askyblock.team.maxsize.<number>
    Hey Galagan;
    • Max team members - askyblock.team.maxsize.<number>
    The perm does work as i am using it on my server, make sure there is nothing conflicting with the issue by checking the config also under team size, So just recheck the perm is allied to there group, otherwise the player in the world "ASkyworld" or what ever you called it.
     
  1. Hello, great plugin..
    Why players can not spawn animals by spawners in the ASkyBlock world?
    Thanks
     
  2. Hey zogoria,

    They should be able to check the flags of __global__ if you use World-guard as Spawners are not controlled by ASkyBlock. Unless you are talking about the limits

     
    • Like Like x 1
  3. Thank you for your great support.
    I discovered my problem, It was by multiverse, the command "/mvm setanimals true" is not working ingame with ASkyBlock world (I dont know why), so I change it by editing the multiverse worlds config, it worked..
    My best wishes..
     
    • Like Like x 1
  4. I was wondering the correct support with multiverse-inventories. I tried to merge the ASkyBlock world with my spawn world and the inventories wouldn't combine, each time I do /is, a different /is inventory is used... Is there a way to fix this? Meanwhile, I will try checking the API for anything I can change.
     
  5. Yes, try not to have multi inventory's.

    Are you using? "http://dev.bukkit.org/bukkit-plugins/multiverse-inventories/"

    In that config you can do this:
    Code (Text):
        example:
            worlds:
            - skyworld
            - world
            - skyworld_nether
            shares:
            - inventory
            - health
    Share codes are the following:
    More information here: https://github.com/Multiverse/Multiverse-Inventories/wiki/FAQ
     

  6. u add in the config too ?
     
  7. Code (Text):
       # Default max team size
       # Use this permission to set for specific user groups: askyblock.team.maxsize.<number>
       # Permission size cannot be less than the default.
       maxteamsize: 4
     
  8. yeah for defautl its ok but when i add exemple: askyblock.team.maxsize.7 player cant invite more
    i got 4 group with perm
    askyblock.team.maxsize.4
    askyblock.team.maxsize.5
    askyblock.team.maxsize.6
    askyblock.team.maxsize.7

    and default maxteam is 3

    i need to add negative perm ?
     
  9. Pm me your IP, i'll come on and look
     
  10. Hey @Tastybento,

    Left you a Github request about this issue! :)
     
  11. Yup, thanks. I fixed this so that it'll use the largest value. I'll push out the update soon. (And you can get it via github too).
     
    • Winner Winner x 1
  12. Hi. I got 2 different A Skyblock servers running and in the newest version there isn't generating a top 10.

    [​IMG]

    Also tryed: /asadmin topten

    [​IMG]

    But no luck.

    [​IMG]

    What could cause this? Thanks in advance!
    (And yes: there are lots of islands and did some restarts)
     
  13. Hey, are there any errors in console?
     
  14. /asadmin topten
    [13:07:24 INFO]: [ASkyBlock] Processed 410 players
    [13:07:24 INFO]: [ASkyBlock] Saving top ten list
    [13:07:24 INFO]: [ASkyBlock] Saved top ten list

    /Is top
    Does not give any output in the console.
     
  15. What's your other Skyblock plugin version? and is it Tastybento ?
     
  16. Weird. Have a look through the console log for any errors. As Steev said, what versions are you running?

    Try this: Remove the file topten.yml from the ASkyBlock folder and then do /asadmin topten. The file should reappear and should be filled with the top ten. This command doesn't actually calculate every island's level, it just searches the player files (in ASkyBlock/players) and grabs the highest values. If the file appears, but is empty, then it would appear all the players have zero island level... You can check the player files themselves to see if that is true or not - would be weird.

    It might be a perms issue, but I doubt it. Need more info -see how the file rebuild goes and see if there are any console errors.
     
    • Like Like x 1
  17. Tastybento updated A Skyblock with a new update entry:

    Tweaks and bug fixes

    Read the rest of this update entry...
     
  18. Nice plugin. It worked for me :)
     
    • Like Like x 1
    • Agree Agree x 1
  19. Deleted the topten.yml but that didn't work.

    But you are right, it looks like the island don't have levels.. In this screenshot you can see the island level and the island in the background.

    [​IMG]

    You said something about a permission based problem?