Spigot AutoRestart 4.2.1

PlaceholderAPI, TitleAPI (fully customizable)

  1. My server is not starting up after this shuts it down
     
  2. Does this work for 1.16.4?
     
  3. I'm running it on 1.16.4 Spigot
     
    • Friendly Friendly x 1
  4. Perfect, thank you buddy :D
     
  5. Hey there.
    I've installed this on my server, and it seems to restart the server in a weird way.
    So I run my server on a Linux virtual server, in a tmux tab. - And it seems to think that after starting the server again, that it's still stopped. Is there any way for it to also update the tmux tab?

    It doesn't seem that the tmux tab latches onto the jar file properly when it's started, which is a problem.
     
  6. >.... [20:59:59 INFO]: ⚠ [PichuBOT] Reinicio Programado en 3 segundos.
    >.... [21:00:00 INFO]: ⚠ [PichuBOT] Reinicio Programado en 2 segundos.
    >.... [21:00:01 INFO]: ⚠ [PichuBOT] Reinicio Programado en 1 segundos.
    >.... [21:00:02 INFO]: ⚠ [PichuBOT] Servidor Reiniciandose, vuelve en un momento.
    >.... [21:00:02 INFO]: JXAKO lost connection: El servidor se esta Reiniciando, vuelve en un momento.
    >.... [21:00:02 INFO]: Startup script './start.sh' does not exist! Stopping server.
    >.... [21:00:02 INFO]: Stopping server
    (...) *plugins shuting down*
    (.........)
    [Pterodactyl Daemon] Server marked as OFF
    [Pterodactyl Daemon] ---------- Detected server process in a crashed state! ----------
    [Pterodactyl Daemon] Exit Code: 0
    [Pterodactyl Daemon] Out of Memory: false
    [Pterodactyl Daemon] Error Response:
    [Pterodactyl Daemon] Server process detected as entering a crashed state; rebooting.
    [Pterodactyl Daemon] Server marked as STARTING
    [Pterodactyl Daemon] Checking size of server data directory...
    [Pterodactyl Daemon] Disk Usage: 817M / 25600M
    [Pterodactyl Daemon] Running server preflight.
    [Pterodactyl Daemon] Starting server container.
     
  7. in spigot.yml i have
    restart-script: ./start.sh
     
  8. hi, we tried using the plugin and we got this msg what do we do? 8.04 05:08:04 [Server] Server thread/INFO Startup script './start.sh' does not exist! Stopping server. 28.04 05:08:04 [Server] Server thread/INFO Stopping server we are using pebblehost
     
  9. Does this plugin happen to support paper? I checked the instructions and I'm supposed to change the restart script.
    I checked the paper.yml file and it didn't have Restart-Script but spigot.yml did however /restart exists on the server so I'm sure there is a paper file with Restart script.
    Of course, my error is "./start.sh' does not exist! Stopping server."
     
  10. Please read the instructions
     
  11. Wait hold on. new problem. I changed the spigot.yml file even when using papermc and it proceeds to use the spigot.yml file for the plugin. My new error is "Startup script 'start.bat' does not exist! Stopping server."
     
  12. Wait hold on! I had to think outside the box a little there even though i was just being stupid. The start.bat is literally the file I use to start the server. I changed my start-server file from serverstart.bat to start.bat and it works now.
     
  13. centos can't restart........
    My start.sh:
    Code (Text):
       java -Xms29000M -Xmx29000M -XX:+UseG1GC -XX:+ParallelRefProcEnabled -XX:MaxGCPauseMillis=200 -XX:+UnlockExperimentalVMOptions -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -XX:G1NewSizePercent=30 -XX:G1MaxNewSizePercent=40 -XX:G1HeapRegionSize=8M -XX:G1ReservePercent=20 -XX:G1HeapWastePercent=5 -XX:G1MixedGCCountTarget=4 -XX:InitiatingHeapOccupancyPercent=15 -XX:G1MixedGCLiveThresholdPercent=90 -XX:G1RSetUpdatingPauseTimePercent=5 -XX:SurvivorRatio=32 -XX:+PerfDisableSharedMem -XX:MaxTenuringThreshold=1 -Dusing.aikars.flags=https://mcflags.emc.gs -Daikars.new.flags=true -jar spigot-1.12.2.jar nogui
     
  14. 1.17 versions a tad broken..
     
  15. I'm not seeing issues on 1.17
     
  16. Error code when plugin is outputing:

    Code (Text):
    [AutoRestart] There was an error in Messenger.broadcastStatus(CommandSender, Status):sendTitle(Player, Popup, Array<Format>) // Global
    [14:37:51 INFO]: java.lang.ClassNotFoundException: net.minecraft.server.v1_17_R1.PacketPlayOutTitle
    [14:37:51 INFO]:        org.serversmc.autorestart.utils.TitleAPI.getNMSClass(TitleAPI.kt:10)
    [14:37:51 INFO]:        org.serversmc.autorestart.utils.TitleAPI.sendTitle(TitleAPI.kt:22)
    [14:37:51 INFO]:        org.serversmc.autorestart.utils.Messenger.sendTitle(Messenger.kt:30)
    [14:37:51 INFO]:        org.serversmc.autorestart.utils.Messenger.broadcastStatus(Messenger.kt:140)
    [14:37:51 INFO]:        org.serversmc.autorestart.cmds.autore.CIn.execute(CIn.kt:78)
    [14:37:51 INFO]:        org.serversmc.autorestart.interfaces.ICommand$DefaultImpls.onCommand(ICommand.kt:93)
    [14:37:51 INFO]:        org.serversmc.autorestart.cmds.CAutoRestart.onCommand(CAutoRestart.kt:10)
    [14:37:51 INFO]: [AutoRestart] End of error
     
    • Like Like x 1
  17. thats the thing I keep running into. I did autors now command and I get a similar error and it doesnt continue..
     
  18. Can you update it to 1.17 one of your bugs arne that i do not see a broadcast title in the middle of the screen when autorestart in counting until 0
     
  19. Does this plugin stop and start the run file again or just stop the server.
     
  20. There hasn't been an update to this plugin in a year, last verified version was for 1.15. Is this still being supported?