Premium AutoSell [Paid]

Discussion in 'Resource Discussion' started by clip, Dec 5, 2014.

  1. N4:
    priority: 4
    shop_list:
    - dye;4,0.130

    this item comes up as entry incorrect, how can I allow lapis lazuli sold for a mine item?
     
  2. Well, in-game do /asa additem {MineName} {Price}
    And hold the lapiz in your inventory while you do that, this should work! If it doesnt please reply

    Currently from what I can see there is not a way to force it on with just autosell. https://dev.bukkit.org/projects/joincommand You can use this plugin to force it on join, if you do not want to do that then you can also use the Multi-Verse Inventories Plugin to Clear their inventory on join!

    ~Thanks Infinityy
    Hope I helped, if I did leave a like
     
    • Like Like x 1
  3. INK_SACK;4,0.130
    --
    Also, @clip please fix the error regarding VKBackpack... I'm on 1.10 and drops2inv won't work
     
  4. Hi i have this problem to the plugin:

    10.03 23:50:13 [Server] WARN [AutoSell] Task #1362 for AutoSell v1.7.0 generated an exception 10.03 23:50:13 [Server] INFO java.lang.NoSuchMethodError: org.bukkit.inventory.PlayerInventory.getStorageContents()[Lorg/bukkit/inventory/ItemStack; 10.03 23:50:13 [Server] INFO at me.clip.autosell.BlockHandler.convertInventoryToBlocks(BlockHandler.java:53) ~[?:?] 10.03 23:50:13 [Server] INFO at me.clip.autosell.tasks.BlocksPlayerTask.run(BlocksPlayerTask.java:27) ~[?:?] 10.03 23:50:13 [Server] INFO at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftTask.run(CraftTask.java:71) ~[minecraft_server.jar:git-Spigot-db6de12-18fbb24] 10.03 23:50:13 [Server] INFO at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:350) [minecraft_server.jar:git-Spigot-db6de12-18fbb24] 10.03 23:50:13 [Server] INFO at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:723) [minecraft_server.jar:git-Spigot-db6de12-18fbb24] 10.03 23:50:13 [Server] INFO at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [minecraft_server.jar:git-Spigot-db6de12-18fbb24] 10.03 23:50:13 [Server] INFO at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [minecraft_server.jar:git-Spigot-db6de12-18fbb24] 10.03 23:50:13 [Server] INFO at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [minecraft_server.jar:git-Spigot-db6de12-18fbb24] 10.03 23:50:13 [Server] INFO at java.lang.Thread.run(Thread.java:745) [?:1.8.0_121]

    How can i solve it?
     
  5. Reading will solve it.
    [​IMG]
     
  6. is /autosell working for everyone else?
     
  7. Yeah, it is!
     
  8. Yeah I've figured it out, they need the mine perm as-well.
     
  9. I'm a developer on a fairly popular server where the owner bought this plugin. Can you please add in a method for selling an item by its id,datavalue, and amount? I see there is one for selling a list of inventories or itemstack, however I do not wish to use either.
     
  10. I need the 1.8 version please.
     
  11. Read my last I made on this page.
     
  12. Used autosell 1.6.6 for my a,8 server and I still get these erros

    14.03 17:05:31 [Server] WARN [AutoSell] Task #1399 for AutoSell v1.6.6 generated an exception
    14.03 17:05:31 [Server] INFO java.lang.NoSuchMethodError: org.bukkit.inventory.PlayerInventory.getStorageContents()[Lorg/bukkit/inventory/ItemStack; 14.03 17:05:31 [Server] INFO at me.clip.autosell.BlockHandler.convertInventoryToBlocks(BlockHandler.java:53) ~[?:?]
    14.03 17:05:31 [Server] INFO at me.clip.autosell.tasks.BlocksPlayerTask.run(BlocksPlayerTask.java:27) ~[?:?]
    14.03 17:05:31 [Server] INFO at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
    14.03 17:05:31 [Server] INFO at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:350) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
    14.03 17:05:31 [Server] INFO at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:723) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52]
     
  13. Read the second box in red on my post................
     
  14. Is it not possible to jus tmake the plugin 1.8.-1.11.2 ? just curious
     
  15. Is it possible to not use a 3+ year old version of Minecraft?

    Sorry for the smart ass answer, but due to all the API changes that have happened over the past three years it's not impossible but it's very hard... Supporting old versions also limits all the new stuff that could be added.
     
  16. Hey, where can I get the API?
     
  17. I spent the day setting up the plugin and its working great, so far no errors on 1.11.2.

    One question, in the config there is the option: "shop_items_info:" under this I have "use_gui: true"

    How can players access the GUI (whats the command it ins't listed with the other commands)?
     
  18. Nevermind found it! :)
     
  19. I have a suggestion for the plugin. After testing some stuff, I noticed it sells named items. So if players are able to sell certain items such as diamond gear it will sell their named stuff too. Perhaps add so named items aren't able to be sold?

    Unless there is a way to work around this (besides players emptying those certain items from their inventory to prevent losing their wanted items before doing /sellall)..