Premium AutoSell [Paid]

Discussion in 'Resource Discussion' started by clip, Dec 5, 2014.

  1. I have provided all the information possible if it is you who doesn't know how to help, you only have to admit that you do not know the problem and do not blame ;)
     
    #1781 Lolok, Apr 23, 2019
    Last edited: Apr 24, 2019
  2. Is this plugin fully updated to work with 1.13.2?
     
  3. clip

    Benefactor

    clip updated AutoSell with a new update entry:

    1.9.0 1.13+ support

    Read the rest of this update entry...
     
  4. @clip
    Hey I found something with Autosell, that allow players to "usebug"

    Of course I have multiple mines. One for each of my groups on my prison server

    But I also have an event mine. It reset each days.
    In this mine I have multiple blocks:
    Emerald_block
    Diamond_block
    etc

    If a player was in his group mine and mine emerald_block and diamond_block, he can simply have a full inventory of those blocks, go in the events mine and sell his blocks in it because the prices are higher than his group mine.


    So do you have a way to prevent this "usebug" to occured?
    I can't change the events mine to lower them. If I do this, the prices will be at 0$ XD

    I know it was not really a usebug, but players use it to exploit the server XD


    Thanks again clip
     
  5. There's nothing in AutoSell to prevent this, and it's most likely unlikely to ever get changed as its the expected result.
    Best option is to look into limiting what players can take into the region, not sure if there's a plugin already made for this, or a custom one would need to be developed
     
  6. @clip please add support to JetsPrisonMine.

    it's the most updated PrisonMine plugin right now.
     
    • Agree Agree x 1
  7. Hey, My question is Why i can´t use ShopGUIPlus for your plugin I finde that not so nice. Can you do it that I can use ShopGUIPlus
     
  8. Why do I continue to get this error and how do I fix it?

    Code (Text):
    [21:32:05 WARN]: [AutoSell] Task #312 for AutoSell v1.9.0 generated an exception
    java.lang.NoSuchMethodError: org.bukkit.inventory.PlayerInventory.getStorageContents()[Lorg/bukkit/inventory/ItemStack;
            at me.clip.autosell.BlockHandler.convertInventoryToBlocks(BlockHandler.java:53) ~[?:?]
            at me.clip.autosell.tasks.BlocksPlayerTask.run(BlocksPlayerTask.java:27) ~[?:?]
            at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftTask.run(CraftTask.java:59) ~[patched.jar:git-TacoSpigot-"95870a93"]
            at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:349) [patched.jar:git-TacoSpigot-"95870a93"]
            at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:785) [patched.jar:git-TacoSpigot-"95870a93"]
            at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:378) [patched.jar:git-TacoSpigot-"95870a93"]
            at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:715) [patched.jar:git-TacoSpigot-"95870a93"]
            at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:618) [patched.jar:git-TacoSpigot-"95870a93"]
            at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212]
     
     
  9. Spigot 1.8 is unsupported by the latest versions of AutoSell, downgrade your AutoSell v1.8.6-1.8-compat or upgrade your spigot to a newer version.
     
  10. autosell stats gives not a correct value with vkautopickup
     
  11. Autosell don´t sell auto you need to send the command /as but you don´t can say in the config join = autosell
     
  12. Hello, before I buy this plugin, may I ask what API events and methods are there?
     
  13. clip

    Benefactor

  14. anyone know how to make this plugin with citizens plugin?
     
  15. Code (Text):
    [19:09:41 WARN]: [AutoSell] Task #558 for AutoSell v1.9.1 generated an exception
    java.lang.NoSuchFieldError: SNOWBALL
     
    Change SNOWBALL to SNOW_BALL. Let me know if you have any other issues, but it does also appear to be conflicting with AsylumMines, but try the item changing first to see if that fixes, if not, please post your configuration and the error that is spewed out in your console. :)
     
  16. where is the snowball? i cant find it in the ocnfig
     
  17. auto sell works right but it still spams it in my console
    what is snowball anyway? where can i find it
     
  18. Just realized something... You are running the latest version of this plugin on 1.12.2... Instead of using the latest version, please downgrade, for as the latest version doesn't support 1.12.2. Here is the download link to the last supported version of AutoSell for 1.12.2: https://www.spigotmc.org/resources/autosell.2157/download?version=209217

    Just use the AutoSell-1.8.6.jar, not the AutoSell-1.8.6-mc-1.8-compat.jar

    Let me know if there are any other issues! :)
     
  19. what is mpat?