Best free Control Panel?

Discussion in 'Systems Administration' started by Diamond_King099, Nov 1, 2016.

  1. I have an OVH VPS with Bungee and two servers that I currently use for testing plugins. I plan on using it as a demo server at some point in the future as well. I'm currently using FTP and PuTTY with some bash scripts, it works but is a bit clunky and doesn't always work that well.

    I'd like to setup a web based CP where I can upload plugins, reboot, access the console, etc. PufferPanel looks nice, and so does PterodactylPanel, I believe they're both made by the same person. These are the only two that I've found that look any good. Has anyone had much experience with either of these, or perhaps know of something else? I would just go ahead and try both, but I'd like to get some sort of feedback before reinstalling my VPS and loosing my current configuration.
     
  2. I made a pufferpanel tutorial but its dutch.. You can just follow the commands etc and you might get in the right place
     
    • Like Like x 4
  3. I tried installing PterodactylPanel, but it wasn't at all straightforward, and I ended up getting access denied errors during one of the steps. I might give it another go sometime, but I just didn't feel like messing with it.

    I gave PufferPanel a go and right off the bat I got "no installation candidate found" for some of the php5 packages. Could it be because I'm running Ubuntu Server 16 as opposed to 15? I doubt it, but the installation instructions didn't list 16 as being supported. I'll just have to work with it some more.
     
    • Friendly Friendly x 1
  4. Strahan

    Benefactor

    Aesthetics should not be a major factor in the decision, functionality should be.
     
  5. Yeah, I agree. Still, those are the only two free ones I could find that seemed decent. I'm sure there are others out there as well, but I just haven't done any further searching.
     
  6. It appears that Ubuntu Server 16.04 doesn't support php5 out of the box. I could add a ppa, or try substituting with php7, but I'll just reinstall with Ubuntu 15.10 and see how that goes.
     
  7. Got PufferPanel installed on Ubuntu Server 15.10. Now onto actually setting up a server...
     
  8. There is a unofficial support for pufferpanel on ubuntu 16.04
     
  9. I'm wondering if I misunderstood what a panel is used for. I have a single VPS, and I want to use the panel as an interface to a server running on the same VPS. However, PufferPanel seems to be oriented for the purpose of working with remote nodes/servers.

    Is it possible to setup a server and use PufferPanel as an interface all on a single VPS?
     
  10. That is one use-case of people who use it. They declare the "node" to be on the same server. There's no difference functionally where that node is.

    Where it explains creating the node, you do that on the same VPS that the panel is on.
     
    • Like Like x 1
  11. Thanks! So far so good.

    Also, I've noticed that the docs show all the commands being run as the root user. I know that for setting up a regular server, it's unsafe to use the root user and is best to create a separate user. Is that not the case with PufferPanel? Even some of the screenshots show running the commands as root:

    [​IMG]
     
  12. When the server is created everything will being ran as a normal/standard user.
     
  13. Ok, thanks. I just ran it all as root.

    So far, PufferPanel is great! Now I just need to update to Java 8, it installed Java 7 by default.
     
  14. So I updated to Java 8 and rebooted. Now when I try to boot up the Spigot server, it says "We were unable to connect to the main Socket IO server, there may be network issues currently".

    Does it require Java 7 as opposed to 8? I hope not, Java 8 is a must for me.

    EDIT: Apparently the Scales service doesn't automatically start up after a reboot, just had to start it back up and it's working again.
     
    #14 Diamond_King099, Nov 2, 2016
    Last edited: Nov 2, 2016
  15. Well the server is up and running, but I'm unable to connect to it in-game. It never stops pinging, and when I try to log in it just times out. I made sure to add a firewall exception as well.

    When I check it with a query tool, it shows up as online, I just can't connect to it in-game. No errors show up in the console either.

    Here's the IP if anyone would like to test it out: 158.69.199.111:25565
     
  16. Reboot the hardware node.
     
  17. Yeah, tried that a couple of times. No luck.

    Strange that the console looks fine, and that Dinnerbone's query tool shows it as online. Maybe I need to set something in the server.properties...
     
  18. So this is strange... A friend of mine was able to login, and I'm able to login to other servers, but when trying to join my PufferPanel one it just times out. Never had an issue like this before...

    Anyone know what could be causing this?
     
  19. if u want to use multicraft i got a key i can give you beacuse ive since switched to xenopanel
     
    • Friendly Friendly x 1
  20. That would be awesome! Thanks!
    You can send me a PM. (link in sig)