Best version for a survival server?

Discussion in 'Minecraft Discussion' started by Andot, Sep 10, 2019.

?

Which version should I use?

  1. Keep on 1.14.4

    5 vote(s)
    71.4%
  2. Downgrade (comment which)

    2 vote(s)
    28.6%
  1. Hello everyone, so currently I'm hosting a semi-anarchy server (it contains some plugins) and the half of these aren't working correctly. Very soon I'm gonna restart the progress on a new improved host. I'm actually using Spigot 1.14, should I downgrade to another version? I'm thinking about 1.12.2 or something like that, but I'm not sure. Thank you for reading!
     
  2. If you are concerned about performance I would recommend 1.13.2
    Theres no reasons to build a new server on anything lower than that, ie: 1.12.2, due to the fact that a lot of plugins available for 1.12.2 have not/will not upgrade to 1.13+, which means your server will forever be stuck on 1.12.2.

    1.14.4 is still pretty performance heavy and not exactly the most stable for running a server.
    nearly 50% of servers right now are on 1.14.4 despite everyone complaining about how bad it is.

    With 1.13.2, you at least have the chance to upgrade pretty easily as 1.14.x didn't change API all that much.
    1.15 is just around the corner (I suspect early 2020 release?!?!), so at least with 1.13.2 you have a chance to upgrade to 1.15 when it comes out, and I think everyone expects 1.15 to fix a lot of these performance issues.

    Do keep in mind when running an outdated version, such as 1.13.2, you might have a hard time getting support from some plugin devs. Often times plugin devs have enough on their plate that they dont want to have to worry about helping people running outdated server versions.
     
    • Agree Agree x 1
  3. Strahan

    Benefactor

    1.14.4? Nahhh you should be running 1.7.10. That's what all the cool kids are doing.

    (in case it wasn't painfully obvious, this is a joke lol)
     
    • Funny Funny x 1
  4. doe anyone here know how to do this permission to a rank so they could break only that block set ?
    essentials.build.break.<id>[:datavalue]
     
  5. wtf does that have to do with this thread?
    Got an issue, create a thread for it.
     
  6. u dont have to be so rude shane i never used this spigot thing b4 thats why i just commented on a recent post for help
     
  7. 25six

    25six Previously PlebFerLyfe

    1. Make your own thread, this is for somebody else
    2. Dont argue with ShaneBee (ever)
     
    • Winner Winner x 2
  8. bruh we ended that already why u trying to start old fire?
     
  9. Celebrimbor

    Patron

    If you plan to have more than 10 players online at any given time, then 1.13.

    If it’s just for friends and family or basic vanilla for a small community, then 1.14.
     
    • Agree Agree x 2
  10. Nine0999

    Nine0999 Previously Neon_Logiik

    1.13 seems to be the better of all of them
     
  11. For survival, I recommend 1.14.4, because of it's features. It enhanced survival experience a lot.
    However, if you are worried about stability, I recommend 1.13.2.
    If you are focusing on performance over experience, use 1.12.2.
    I don't see any point in using anything lower than 1.12.2 for survival.

    That's not being new to Spigot, that's being new to forums in general.