Spigot BetterRTP | Random Wild Teleport 3.1.0-3

A random teleport plugin for staying between the WorldBorder! Custom restrictions and more

  1. SuperRonanCraft submitted a new resource:

    BetterRTP - An RTP plugin best suited for staying between the WorldBorder!

    Read more about this resource...
     
  2. SuperRonanCraft updated BetterRTP with a new update entry:

    Bug Fixes!

    Read the rest of this update entry...
     
    • Agree Agree x 1
  3. SuperRonanCraft updated BetterRTP with a new update entry:

    Placeholders! And Bug Fixes

    Read the rest of this update entry...
     
  4. SuperRonanCraft updated BetterRTP with a new update entry:

    Bug Fixes - Reload Command and Permissions!

    Read the rest of this update entry...
     
  5. SuperRonanCraft updated BetterRTP with a new update entry:

    1.6.1 - Small Config change

    Read the rest of this update entry...
     
  6. A good plugin
    Can I reprint it to www.mcbbs.com
    It's a forum about Minecraft
    :)
     
  7. Sure, link doesn't work, but as long as you don't paste the .jar, go ahead I guess?
     
  8. SuperRonanCraft updated BetterRTP with a new update entry:

    1.6.2 - Command update!

    Read the rest of this update entry...
     
  9. Hi! Love that you can customise the messages, makes it better than another rtp plugin out there. ;)

    However, I do seem to have one rather big flaw. /rtp is teleporting my players all to roughly the same location..

    Code (Text):
    # BetterRTP plugin by SuperRonanCraft! (Join my Public Server mc.RonanCraft.net) #
    # Please give me credit, I'm a first time coder, and would love to see more discussions on my Spigot page! #

    #DO NOT TOUCH!
    Version: 1.6.2

    ## If WorldBorder is set to false, it won't use the worldborder set by the vanilla /worldborder! # ##Highly Recommended##
    UseWorldBorder: true
    ## If WorldBorder is set to true above, these values WILL be ignored! #
    ## Must be a positive integer #
    MinRadius: 320
    ## Maximum amount of tried before BetterRTP gives up and sends a NotSafeMessage #
    MaxAttempts: 15

    ## WorldBorder Must be "false" to have these options listened to #
    RandomTp:
        MaxRadius: 1000
        MinRadius: 100
        CenterX: 0
        CenterZ: 0

    ## Prefix of every message #
    Prefix: '&7ยป &7 '
    ## Place Holders! %x% %y% and %z% are the x, y, and z coordinates that the player is being teleported to! #
    SuccessMessage: 'You have been teleported to to&7 x=%x% y=%y% z=%z%'
    NotSafeMessage: 'Could not find safe spot within %attempts% attempts! &7You were not RTP''d!'
    ReloadMessage: '&eConfig reloaded successfully!'
    NoPermission: '&cSorry! &7You don''t have permission to use this command!'
    ## %world% is the world the player is in that is disabled to rtp in! #
    DisabledWorldMessage: '&cDisabled World %world%! &7Could not RTP!'

    ## Blocks RTP will try to not teleport onto. More Blocks at: https://hub.spigotmc.org/javadocs/bukkit/org/bukkit/Material.html #
    BlacklistedBlocks:
        - stationary_water
        - stationart_lava
        - cactus
        - leaves
        - leaves_2

    ## Worlds to NOT allow rtp to function #
    DisabledWorlds:
        - world_nether
        - world_the_end
        - world_games
        - world_parkour
        - world_creative
     
    This is my config, I do have the latest worldborder operating fine. Any suggestions? I should add that for some reason it always teleports players to roughly -9000 -9000, which is one of the corners on my world border.
     
  10. I should also add that the numbers on the messages are quite odd, see screenshot below. The don't match up to the actual location it teleports you to.

    [​IMG]
     
  11. Do you have a WorldBorder setup in Vanilla commands? Or just have the basic 60 mil Worldborder? If so I can't tell you what errors you'll find there. Try using the plugin with the Worldborder to false and edit the center and min/max values there
     
  12. Hello, I use this https://dev.bukkit.org/projects/worldborder for world border (I'm assuming thats what most people use).
     
  13. nonononono, that is not supported, it's the VANILLA version of the worldborder, remove that plugin and just type "/worldborder center <CenterX> <CenterZ>" (Or go to spawn and type "/Worldborder center ~ ~"). Then type the radius of the worldborder "/worldborder set <radius>"
    If you use the plugin without a standard worldborder, you WILL create a chunk extremely far away from spawn.
     
  14. Ah ok, unfortunately I need that plugin, ok, no worries!
     
  15. You could just setup the plugin without using the worldborder, just set the maximum and minimum radius and set the centerX and the CenterZ and the plugin should work the same. Worldborder is just nicer cause you don't have to configure too much :)
    P.S: Worldborder in vanilla is basically like a big box where players can play, and cant walk into the rest of the world, just incase you didn't know, kinda of an unknown thing I guess :)
     
  16. It works well using the max and min radius, however players are sometimes teleporting in to water or lava even though they are on the blacklisted blocks?
     
  17. Never mind last post, adding water and lava as well as stationary water and lava seems to have sorted that. Only thing that would make this perfect then is to be able to set min and max radius per world, as some worlds are larger than others. :)