Spigot Block-Placer 1.1

Change dispenser to Block-Placer

  1. abilnfMC submitted a new resource:

    Block-Placer - Change dispenser to Block-Placer

    Read more about this resource...
     
  2. Can you update this plugin?

    [20:08:58] [Server thread/ERROR]: Could not load 'plugins\BlockPlacer.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: net/minecraft/server/v1_11_R1/Packet
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:133) ~[spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:326) ~[spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:248) [spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.loadPlugins(CraftServer.java:304) [spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:205) [spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545) [spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_144]
    Caused by: java.lang.NoClassDefFoundError: net/minecraft/server/v1_11_R1/Packet
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_144]
    at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_144]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    ... 6 more
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_11_R1.Packet
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_144]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_144]
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_144]
    at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_144]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[spigot-1.12.1.jar:git-Spigot-65e8124-357b573]
    ... 6 more
     
  3. You are using Spigot 1.12.1? 1.11 is only the version can be supported.

    P/S: Backward to 1.8?
     
  4. Would it be possible to update to 1.12? It's a really cool plugin!
     
    • Like Like x 1
  5. abilnfMC updated Block-Placer with a new update entry:

    1.12.2 Update

    Read the rest of this update entry...
     
  6. Updated!
    P.S. It really makes me happy that you like my work!
     
  7. Thanks so much bro! Your plugin is actually a core plugin on my server I'm working on. Thanks for the quick update! :)
     
  8. No Problem bro! ;)
     
  9. abilnfMC Would it be possible if you are still around, to get a update to this plugin?