Spigot BountyHunters Legacy 2.2.6

Kill players, claim bounties!

  1. Are the placeholders parsed in /papi parse <username> %bounty_hunters_progress% ? If so, I have no idea why they would not display in that GUI
     
  2. Apologies for the delay @Indyuce . Placeholders arent displaying data even when using that command.

    upload_2019-7-29_11-0-38.png

    I am currently using 1.12.2 not sure if that could be breaking anything. Going to update to spigot latest today and let you know if anything changes.
     
  3. There is no need of downloading an extra addon. Placeholders automatically register
     
  4. Hey, when I try to add a bounty or use any command that is with the bountyhunter plugin it just does not work and throws back this error message.
    An internal error occurred while
    attempting to perform this command
     
  5. Check your console for startup or join errors. Most of the time, logs give you enough info to fix your issue
     
  6. Hi, I am having issues with default users being able to purchase or right click the tracking compass. Once right clicked it gives the error "You do not have enough permissions" is there a certain permission I need to add manually in order for this to work? Thanks, great plugin either way!
     
    • Agree Agree x 1
  7. Hello, I have this bug, I do not know why or how:


    >.... [15:54:03 INFO]: Sly941 issued server command: /bounties
    >.... [15:54:04 ERROR]: null
    org.bukkit.command.CommandException: Unhandled exception executing command 'bounties' in plugin BountyHunters v2.2.6
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:47) ~[patched_1.14.4.jar:git-Paper-171]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:159) ~[patched_1.14.4.jar:git-Paper-171]
    at org.bukkit.craftbukkit.v1_14_R1.CraftServer.dispatchCommand(CraftServer.java:739) ~[patched_1.14.4.jar:git-Paper-171]
    at net.minecraft.server.v1_14_R1.PlayerConnection.handleCommand(PlayerConnection.java:1800) ~[patched_1.14.4.jar:git-Paper-171]
    at net.minecraft.server.v1_14_R1.PlayerConnection.chat(PlayerConnection.java:1707) ~[patched_1.14.4.jar:git-Paper-171]
    at org.bukkit.craftbukkit.v1_14_R1.entity.CraftPlayer.chat(CraftPlayer.java:453) ~[patched_1.14.4.jar:git-Paper-171]
    at me.mattstudios.citizenscmd.utility.Util.lambda$doCommands$1(Util.java:339) ~[?:?]
    at org.bukkit.craftbukkit.v1_14_R1.scheduler.CraftTask.run(CraftTask.java:84) ~[patched_1.14.4.jar:git-Paper-171]
    at org.bukkit.craftbukkit.v1_14_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:452) ~[patched_1.14.4.jar:git-Paper-171]
    at net.minecraft.server.v1_14_R1.MinecraftServer.b(MinecraftServer.java:1147) ~[patched_1.14.4.jar:git-Paper-171]
    at net.minecraft.server.v1_14_R1.DedicatedServer.b(DedicatedServer.java:417) ~[patched_1.14.4.jar:git-Paper-171]
    at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:1074) ~[patched_1.14.4.jar:git-Paper-171]
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:918) ~[patched_1.14.4.jar:git-Paper-171]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212]
    Caused by: java.lang.NullPointerException
    at java.lang.String.replace(String.java:2240) ~[?:1.8.0_212]
    at net.Indyuce.bountyhunters.api.CustomItem$Builder.format(CustomItem.java:140) ~[?:?]
    at net.Indyuce.bountyhunters.api.CustomItem$Builder.build(CustomItem.java:128) ~[?:?]
    at net.Indyuce.bountyhunters.gui.BountyList.getInventory(BountyList.java:57) ~[?:?]
    at net.Indyuce.bountyhunters.command.BountiesCommand.onCommand(BountiesCommand.java:40) ~[?:?]
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:45) ~[patched_1.14.4.jar:git-Paper-171]
    ... 13 more
     
    • Like Like x 1
  8. I am trying to use your bounty hunter plugin on 1.14.3 and I keep receiving “An internal error occurred” Do you know how I can fix this issue?
     
  9. Is there no way to have new updates with 1.8.8+ compatibility? Like having 2 versions of the same plugin
     
  10. Hello, I'm getting an error when using /bounties, My server is on 1.8.8 :
    Code (Text):
    Error executing task
    java.util.concurrent.ExecutionException: java.lang.NullPointerException
            at java.util.concurrent.FutureTask.report(FutureTask.java:122) ~[?:1.8.0_222]
            at java.util.concurrent.FutureTask.get(FutureTask.java:192) ~[?:1.8.0_222]
            at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:45) [spigot.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:715) [spigot.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [spigot.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [spigot.jar:git-Spigot-db6de12-18fbb24]
            at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [spigot.jar:git-Spigot-db6de12-18fbb24]
            at java.lang.Thread.run(Thread.java:748) [?:1.8.0_222]
     
  11. # Permission needed to track a
    # player and to buy the compass.
    permission: ' '

    How do you use this?
     
  12. Set it to something like 'compass.use-buy' and give your players this permission
     
    • Winner Winner x 1
  13. Hi, i have tested the plugin in my server of 1.14.4 paperspigot but, with the latest version of vault for 1.14.4 dont detect that and say that are not loaded so the plugin dont load, can you fix that please?
     
  14. Look at your console, it tells what's wrong 99% of the time.
     
  15. The problem is that the plugin load before that vault.


    [INFO] .... [BountyHunters] Enabling BountyHunters v2.2.6

    [INFO] .... [BountyHunters] Detected Server Version: v1_14_R1

    [ERROR] .... [BountyHunters] Couldn't load Vault. Disabling...

    [INFO] .... [BountyHunters] Disabling BountyHunters v2.2.6

    [INFO] .... Done (49.019s)! For help, type "help"

    [INFO] .... Starting GS4 status listener

    [INFO] .... Timings Reset

    [INFO] .... Query running on 0.0.0.0:41814

    [INFO] .... [Vault] Checking for Updates ...

    [INFO] .... [Vault] No new version available

    And if i use plugman by example for reload that:


    [INFO] ....>.... [BountyHunters] Enabling BountyHunters v2.2.6

    [INFO] .... [BountyHunters] Detected Server Version: v1_14_R1

    [ERROR] .... [BountyHunters] Couldn't load Vault. Disabling...

    [INFO] .... [BountyHunters] Disabling BountyHunters v2.2.6

    [INFO] .... [PlugMan] BountyHunters has been reloaded.
     
  16. Do you have an economy plugin installed?
     
  17. I have vault.
     
  18. Do you even know what Vault is? It is not an economy, nor chat, nor permission plugin. It's something to help other plugins hook onto eco/perm/chat based systems. Please learn about the plugins you are using before asking for support