1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Solved Bug with command blocks and commandBlockOutput

Discussion in 'Bugs & Feature Requests' started by TheOnlyRealTGS, Aug 14, 2013.

  1. TheOnlyRealTGS

    Supporter

    If commandBlockOutput is false (gamerule), it still prints command block server commands to the console.
    My command blocks are spamming the server with 100+ lines every second which can create lag.
    An example from the console:
    Code (Text):
    > 16:01:49 [INFO] CommandBlock at -1,573,103,-1,300 issued server command: /clear daedae8 373:16462
    Using Build #1080
    Didn't happen on older builds
     
  2. Dmck2b

    Services Staff

    Unable to replicate on Spigot 1080 without plugins.

    [​IMG]

    For note, this is not vanilla behaviour either. Same setup produced this on vanilla server.

    [​IMG]

    Command is iterated once, though multiple attempts are made. Tied a commandblock up to a 2 tick pulser, on Spigot above command attempts are spammed while vanilla only notifies you of successful events. Might be the way it is coded for Spigot/Bukkit?
     
    #2 Dmck2b, Aug 14, 2013
    Last edited: Aug 14, 2013
  3. TheOnlyRealTGS

    Supporter

    Okay try with this code:
    Code (Text):
    /clear @a 403[r=5000]
     
  4. Same thing as you bro... :O
     
  5. Dmck2b

    Services Staff

    With that I got 0 output.

    [​IMG]
     
  6. Wow... about 2 seconds... i come back... see someone replyed... :p
     
  7. TheOnlyRealTGS

    Supporter

    Okay ill try my setup, on a vanilla server
     
  8. TheOnlyRealTGS

    Supporter

    Cannot reproduce on a vanilla server, i have no idea what cause it. Help would be greatly appreciated!
    My plugins:
    Edit: I found out. It's the dev version of essentials. Ill talk to them instead.
     
  9. Dmck2b

    Services Staff

    Just finished some testing on my locally cloned server (Since I was looking into another bug/custom patch anyway) And the plugin responsible is the base essentials jar.

    No idea how to disable it right now, no clear option in config.yml
     
  10. TheOnlyRealTGS

    Supporter

    I saw this a second after editing my post xD Ty for help anyway :)
     
  11. If you want to disable it, go decompile essentials and take out the module... :p
     
  12. TheOnlyRealTGS

    Supporter

    Not a coder myself, so i have no idea how to do it. If you could tell me what to take out, i might be able to do it.
     
  13. Dmck2b

    Services Staff

  14. Disable "clear" command in essentials, it will take it back to vanilla handler.
     
  15. TheOnlyRealTGS

    Supporter

    Hi,
    Thanks so much for your interest in helping me.
    Could you please use a dev build? I need some of the features in it.
    http://ess.ementalo.com/viewType.html?buildTypeId=bt2
     
  16. Dmck2b

    Services Staff


    There's the option in the default essentials config.


    I actually used the latest Ver 2 build from their github to make that, does it not have what you need?
     
  17. TheOnlyRealTGS

    Supporter

    I couldn't really see, it was named TeamCity, but thanks :)