1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

bug?

Discussion in 'Bugs & Feature Requests' started by stefan9459, Jul 30, 2013.

  1. Hello,

    I have 5 worlds when there are like 60 players online sometimes the tps drops to 15 what creates lagg.
    But my cpu is 60% and i have still 3.5 gb ram left whats causes the tps drop?
    i'm using spigot #1047

    Hope somebody can help me

    Greetings Stefan
     
  2. Dmck2b

    Services Staff

  3. Okay thanks i will give a timing. Shall i run the timing for 30 minutes or only when it lags because atm it doesn't lag
     
  4. Dmck2b

    Services Staff


    That might not be the root cause, so I wouldn't do that yet.
     
  5. joehot200

    Supporter

    Give us a timings report please.
     
  6. i'm running it now
     
  7. #8 stefan9459, Jul 30, 2013
    Last edited: Jul 30, 2013
  8. joehot200

    Supporter

    AntiJoinBot is causing WAYYYY Too much lag - i have no idea how it could cause that much lag, i made a custom anti-spambot plugin that does not even show 1%.
    Simple player list is adding to the lag when a player joins, however may not cause too much lag on its own.
    CustomMessages is again causing a lot of lag on join/quit, i suggest you take that out also.

    With 74 players joining/leaving (pretty much the same as me now) each of them joining will cause you massive lag.
     

  9. Thank you very much for your help ^^
    I will look if it will increase my performance
     
  10. I removed antijoinbot and custommessages but i can't remove simpleplayerlist because it's for my site
    this is the new timing
    http://aikar.co/timings.php?url=5930170
     
  11. joehot200

    Supporter

    Yep, your timings are much better :)
     
  12. Thank you so much for your help :)