Build Tools Help Please - Requires 512 Memory

Discussion in 'Spigot Help' started by pitsbrgparatrpr, Jan 1, 2019.

Thread Status:
Not open for further replies.
  1. Hi,
    I updated to the latest buildtools to get the latest version of Spigot to run on a server hosted for us by gameservers. Its telling me I only have 247 Ram, and the issue can be I may have a 32 bit system so it will not run the newest build I want to plop on the server?

    I'm not real good at all of this, but my PC thats running this is 64 bit and I should have a ton of Ram, never had an issue until this latest buildtools? Is there something I can change in my settings, or do to get this? Again, any help would be great, I'm a novice at this etc.

    Thanks, any help would be great.
  2. I'm currently having the same issue

    • Like Like x 1
  3. Strahan


    32/64 bit is irrelevant when you are talking such a low amount of RAM. You can try using the -Xmx / -Xms flags to set memory at or above 512 MB to see if it makes it happy.
  4. Thanks, that worked! My stupid self didn't even read the console error completely and it recommends doing that :(
  5. It could also be that you have downloaded the wrong Java version (32 bit intead of 64 bit)
    x86 = 32 bit
  6. Strahan


    At the low RAM levels mentioned, 32/64 bit is irrelevant.
  7. I believe that md_5 said it was related to differences between recent Java versions (9/10/11) and a Linux issue.
    The easy solution is to use Java 8.
  8. md_5

    Administrator Developer

    Not an issue anymore, BT checks for like 450mb but tells you it wants 512mb.

    247mb like op had is way below
  9. I had this same issue, it was popping up the exact same number (even though it is wildly inaccurate for the computer I am using.) If you set the memory requirement manually to about 500, it should work. That was the only thing I could get to work with mine.
  10. i have the same issue but on the raspberry pi
    can anyone help me

    " sudo java -jar BuildTools.jar
    BuildTools requires at least 512M of memory to run (1024M recommended), but has only detected 237M.
    This can often occur if you are running a 32-bit system, or one with low RAM.
    Please re-run BuildTools with manually specified memory, e.g: java -Xmx1024M -jar BuildTools.jar "
  11. Strahan


    ...did you even read the thread or, for that matter, the error text?
  12. Yes but that dont work on A pi
  13. Why just spigot create a direct download links instead of buildtools? Or just, give a file which downloads the patched jar in diff directory (for example ./cache) without that much things as buildtools says us and then the server loads up?
  14. Distributing parts of Minecraft's code is against the Minecraft EULA. You can distribute patches and patchers, however.
  15. Strahan


    Huh? You can use the Xmx / Xms options on Pi.
  16. Do I just run this exact command? "java -Xmx1024M -jar BuildTools.jar" because when I type this command in, it says to not use special characters so I'm confused. I'm not really a computer person, just trying to update Spigot.
  17. Just 'java -jar BuildTools.jar' should be fine
  18. OK, this is probably a reeealy dumb question, but how do you manually specify the memory?
  19. Necro-posting. Please don't do this again. To answer your question:
    java -Xms(memory)G/M -Xmx(memory)G/M -jar (jar)

    Xms is the memory that is usually allocated to the JVM. This can be as low as 128M, as JVM will automatically allocate more if required.
    Xmx is the maximum amount of memory the JVM can use. Xms will never be higher than this value.
Thread Status:
Not open for further replies.