BuildTools "Child module does not exist"

Discussion in 'Spigot Help' started by TheExoduser, May 8, 2015.

  1. Hey there,

    I'm trying to run the spigot BuildTools as a Job on my Jenkins CI Server.
    I've tried to execute the jar file with this command (Note: I'm on a Windows Server so I'm calling the sh.exe from git for Windows, even though it also should work without the sh.exe):
    Code (Text):
    sh --login -i -c "curl -z BuildTools.jar -o BuildTools.jar https://hub.spigotmc.org/jenkins/job/BuildTools/lastSuccessfulBuild/artifact/target/BuildTools.jar && java -jar BuildTools.jar"
    If I execute the above command in the git bash for Windows it executes without a problem and my spigot.jars are being built. I can even run the command on a normal cmd or PowerShell window and it runs without a problem.
    But if I execute the command (with or without the sh.exe) in Jenkins the build process always gets stuck at this annoying error
    Attempting to build Minecraft with details: VersionInfo(minecraftVersion=1.8.3, accessTransforms=bukkit-1.8.3.at, classMappings=bukkit-1.8.3-cl.csrg, memberMappings=bukkit-1.8.3-members.csrg, packageMappings=package.srg)
    Starting download of https://s3.amazonaws.com/Minecraft.Download/versions/1.8.3/minecraft_server.1.8.3.jar
    Downloaded file: work\minecraft_server.1.8.3.jar with md5: cdd49c262cb98db636b8fae2837869ef
    Final mapped jar: work\mapped.73f3c166.jar does not exist, creating!
    Loading mappings
    1 packages, 0 classes, 0 fields, 0 methods
    Remapping final jar
    [INFO] Scanning for projects...
    [ERROR] The build could not read 1 project -> [Help 1]
    [ERROR]
    [ERROR] The project org.spigotmc:spigot-parent:dev-SNAPSHOT (C:\Program Files (x86)\Jenkins\jobs\SpigotMC\workspace\pom.xml) has 2 errors
    [ERROR] Child module C:\Program Files (x86)\Jenkins\jobs\SpigotMC\workspace\Spigot-Server of C:\Program Files (x86)\Jenkins\jobs\SpigotMC\workspace\pom.xml does not exist
    [ERROR] Child module C:\Program Files (x86)\Jenkins\jobs\SpigotMC\workspace\Spigot-API of C:\Program Files (x86)\Jenkins\jobs\SpigotMC\workspace\pom.xml does not exist
    [ERROR]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [sh, C:\Program Files (x86)\Jenkins\jobs\SpigotMC\workspace\apache-maven-3.2.3/bin/mvn, install:install-file, -Dfile=work\mapped.73f3c166.jar, -Dpackaging=jar, -DgroupId=org.spigotmc, -DartifactId=minecraft-server, -Dversion=1.8.3-SNAPSHOT]
    at org.spigotmc.builder.Builder.runProcess(Builder.java:492)
    at org.spigotmc.builder.Builder.main(Builder.java:278)
    C:\Program Files (x86)\Jenkins\jobs\SpigotMC\workspace>exit 1
    Build step 'Execute Windows batch command' marked build as failure
    Archiving artifacts
    Recording fingerprints
    Finished: FAILURE

    Anyone here who has an idea what's the Problem? Any help would be very much appreciated!

    Edit: I've also tried to move Jenkins into a path without spaces -> same result
     
    #1 TheExoduser, May 8, 2015
    Last edited: May 8, 2015