Solved BuildTools crashing when attempting to build new jars.

Discussion in 'Spigot Help' started by Codewow, Apr 18, 2017.

  1. Getting this when I attempt to build new jars for the latest revision.

    Attempting to build version: 'latest' use --rev <version> to override
    Found version
    {
    "name": "1225",
    "description": "Jenkins build 1225",
    "refs": {
    "BuildData": "8df2731012bb6887630ce7ebd4c7220eabe49a07",
    "Bukkit": "6751fefdda0b171e0830d31e701d4be66af73c9d",
    "CraftBukkit": "e04a1793ae35519baf1f9e1b94c812a6e6712d5a",
    "Spigot": "54ec0b8b502d298334e7011c0a5065777e22421b"
    },
    "toolsVersion": 47
    }

    Pulling updates for C:\Users\Dylan\Desktop\Spigot\BuildData\.git
    Successfully fetched updates!
    Checked out: 8df2731012bb6887630ce7ebd4c7220eabe49a07
    Pulling updates for C:\Users\Dylan\Desktop\Spigot\Bukkit\.git
    Successfully fetched updates!
    Checked out: 6751fefdda0b171e0830d31e701d4be66af73c9d
    Pulling updates for C:\Users\Dylan\Desktop\Spigot\CraftBukkit\.git
    Exception in thread "main" org.eclipse.jgit.api.errors.JGitInternalException: Exception caught during execution of reset command. Cannot lock C:\Users\Dylan\Desktop\Spigot\CraftBukkit\.git\index
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:228)
    at org.spigotmc.builder.Builder.pull(Builder.java:529)
    at org.spigotmc.builder.Builder.main(Builder.java:258)
    Caused by: org.eclipse.jgit.errors.LockFailedException: Cannot lock C:\Users\Dylan\Desktop\Spigot\CraftBukkit\.git\index
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:250)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:327)
    at org.eclipse.jgit.dircache.DirCache.lock(DirCache.java:293)
    at org.eclipse.jgit.lib.Repository.lockDirCache(Repository.java:1182)
    at org.eclipse.jgit.api.ResetCommand.checkoutIndex(ResetCommand.java:378)
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:201)
    ... 2 more
     
  2. electronicboy

    IRC Staff

    Delete the contents of the buildtools folder (other than the jar) and try running it again
     
    • Informative Informative x 1
  3. Thanks. It worked. Should have tried that to begin with. ;)