BuildTools -Git Premission Denied

Discussion in 'Spigot Help' started by TobiKraft, May 29, 2017.

  1. Hello Guys my Problem is i tried to get the Spigot.jar but when i became a Error.
    i have Googled this error. I didnt find anything. How can i fix this?
    I start the BuildTolls with Git. I tried the command :
    git rebase --abort
    but i became :
    fatal: Not a git repository (or any of the parent directories): .git
    I know this is a English platform but it were be easier for me when you say it on German.

    fatal: could not open .git/rebase-apply/author-script for writing: Permission denied
    Something did not apply cleanly to Spigot-Server.
    Please review above details and finish the apply then
    save the changes with rebuildPatches.sh
    Error compiling Spigot. Please check the wiki for FAQs.
    If this does not resolve your issue then please pastebin the entire BuildTools.log.txt file when seeking support.
    java.lang.RuntimeException: Error running command, return status !=0: [sh, applyPatches.sh]
    at org.spigotmc.builder.Builder.runProcess(Builder.java:561)
    at org.spigotmc.builder.Builder.main(Builder.java:443)


    On the bottom you see the Log File from Buildtools.
     

    Attached Files:

  2. electronicboy

    IRC Staff

    try deleting the craftbukkit folder in buildtools and running it again; Also, be weary that antivirus software can cause issues similar to that with git
     
  3. Es kann auch sein das die Firewall dazwischen funkt sowohl die deines PCs als auch die deines Routers
     
  4. Thank you for Helping. I will try it at the evening. I will say when it doesnt work.