BuildTools Updates & Information

Discussion in 'News and Announcements' started by md_5, Jan 5, 2015.

Thread Status:
Not open for further replies.
  1. Ok! Thank you for simplifying it! I might wait awhile untill it is more simplified and/or i am used to it! @md_5
     
  2. Really great job once again, @md_5 and the rest of the Spigot crew. :)
     
  3. What do you mean? The first post has a link to the Oracle Java downloads. I don't see OpenJDK mentioned anywhere.
     
  4. Does this support 1.8? because the 1.8 blocks when i place them dont stay, instantly get removed.
     
    • Funny Funny x 1
    • Creative Creative x 1
  5. I must have skipped it. They did mention Oracle prior to that.

     
  6. Good Job, thanks!
     
  7. This happened when i tried to rebuild spigot for my server. It is first time i see this kind of errors.

    Code (Text):
    [ERROR] Failed to execute goal org.apache.maven.plugins:maven-shade-plugin:2.3:shade (default) on project craftbukkit: Error creating shaded jar: Error in ASM processing class com/mysql/jdbc/NdbLoadBalanceExceptionChecker.class: 26725 -> [Help 1]
    [ERROR]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR]
    [ERROR] For more information about the errors and possible solutions, please read the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [sh, /media/lv2/Build/minecraft/spigot/apache-maven-3.2.3/bin/mvn, clean, install]
        at org.spigotmc.builder.Builder.runProcess(Builder.java:386)
        at org.spigotmc.builder.Builder.main(Builder.java:305)
     
     
  8. i dont think this works with 32 bit java? wait dose it?
     
  9. It's feature complete. We built a huge fort out of mined granite, denite, and an???nite tonight
    Imo, the major bugs left are mostly edge cases. Looks like about 14000 servers are running 1.8.1 on spigot as of yesterday (source: mcstats).
     
  10. I have had this before and it has generally been quickest to move buildtools.jar and build.sh to a new build folder and try to build. If it still doesn't build- there is a problem. If it builds, remove the old build folder.
     
    • Winner Winner x 1
  11. jflory7

    jflory7 Retired Moderator
    Retired Benefactor

    *quietly adds in Fedora 21 command line syntax for Java 8*
     
    • Like Like x 1
  12. This seem to fix it. I deleted spigot build and maven repository folders and it went fine. TY very much.
     
    • Friendly Friendly x 1
  13. Are you sure you actually starting the new version for your server? spigot-1.8-R0.1-SNAPSHOT.jar?
     
  14. Updated to 1.8.1 or whatever the current is, and no ranks, no color works on the server. No commands work.. bug?
     
  15. Alright, screw the Mac users -- can we just go back to the old way which gave me no errors? LOL ;)

    I'd be lying if I didn't say that I was thinking exactly that when trying to update to Build #22 and encountered a TON OF ERRORS, even though nothing on my PC had changed from successfully compiling all the previous builds from day one until #19, and I was using the correct new bash command to run it, etc. I've never just compiled the new build on top of the old one -- I've always started in a new folder, so I knew that couldn't be the problem.

    SOLUTION:
    Turns out that the BuildTools.jar either
    (1) Does not like it when you put it in deeply nested folder tree, and/or
    (2) It also might be objecting to a few of the characters I used in those folder names (like the # symbol, parentheses, etc.).

    So I created a folder (with a simple name) right off the root (c:\), put the latest BuildTools.jar in there, started Git Bash in there by right-clicking, ran the new command, and presto! Worked like a charm just like it always has for me.

    So, in summary, it's probably not a good idea to start the BuildTools.jar in a path like:
    "C:\Program Files (x86)\Minecraft\Spigot v1.8 Compile Tools\Compiled #22\"

    Hope this helps someone else.

    PS - Thanks again, Spigot Team! And I actually am happy that Mac users are now fully in on this (at least now that my problem is solved....haha)
     
    • Informative Informative x 2
  16. minecraft7net

    Supporter

    please add version number / change to running log :

    [21:55:51] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-eb39b47-0899683 (MC: 1.8) (Implementing API version 1.8-R0.1-SNAPSHOT-b240)
     
  17. Many plugins do not work on MC 1.8.x yet. You might look for alternatives, or ask the author of the plugins for any known news on updates.
    What plugins are you using that are not working as they should? I know that when I went to Spigot 1.8.x, Worldguard and Essentials were not working, but the links to them on the previous post about Buildtools.jar worked perfectly.
     
  18. ....no skill, lack of following directions, or just plane laziness.
     
  19. Can we at least keep the atmosphere around here positive? He may not have known about the previous post details. We all make mistakes due to the unknown.
     
Thread Status:
Not open for further replies.

Share This Page