BuildTools Updates & Information

Discussion in 'News and Announcements' started by md_5, Jan 5, 2015.

Thread Status:
Not open for further replies.
  1. You need to run BuildTools and wait for it to finish which may take about ~5-10 minutes. After that you can put the jars where you want.
     
  2. Yeah, I almost started work on a program that would replace BuildTools for those that couldn't handle dealing with the JDK, Git, and Command Prompt stuff. It looks like this update solves that problem though, so I won't bother writing the program unless someone asks for me to do so.
     
  3. Thank you! Also, is there any explanation of this or documentation explaining how to properly get things squared away?

    Probably sounding pretty noobie here... Just want to get everything right as soon as I can
     
  4. md_5

    Administrator Developer

    Just use minecraft.command.name for Minecraft commands?
     
  5. Exactly what I needed clarified. Just wanted to be sure nothing else was involved in the change to use them.

    I really appreciate all of your work and dedication. Thank you, again!
     
  6. How do I start the server now?
     
    • Like Like x 1
  7. Hi all,

    I have been at this for the last 12 hours and I'm stumped :(
    I get down to running buildtools however the attached error occurs.
    The spigot directory is created, however the jar files and sub directories are not.
    I am running a fresh install of Raspbian on a B model pi (java 1.8 installed by default).

    Any ideas?
    Thanks.

    edit: I should mention that this is all being compiled using putty (SSH).
     

    Attached Files:

  8. MikeA

    MikeA Retired Moderator
    Retired Benefactor

    It's running out of memory, BuildTools needs at least 1GB+ RAM to work. You won't be able to use this on a Raspberry PI.
     
    • Informative Informative x 1
  9. What's a MAC ? ;-)
     
    • Like Like x 1
    • Agree Agree x 1
    • Funny Funny x 1
  10. Ah, cheers for that. I'll try compiling on my PC then transferring the .jar to the pi.

    Thanks.
     
  11. SUCH WOW
    MUCH LOVE
    MANY THANKS
     
    • Like Like x 2
    • Agree Agree x 2
    • Funny Funny x 1
  12. who dahell is trying to compile Spigot on a RBPI
    Wow thats it like trying to stick a camel through the eye of the needle.
     
  13. I tried too, as it would be really convenient. Imagine running a crontab downloading BuildTools, compiling Spigot and making it available to download over a website/ftp... However, I ran into the same problem.
     

    Attached Files:

  14. md_5

    Administrator Developer

    If Minecraft doesn't run on it, we don't support it.
     
  15. @md_5 Well Raspberry can run the pi edition of Minecraft, so that's a bit irritating...
     
  16. Guys do you think i should use essentials or command book? I'm so confused
     
  17. There is a problem with your essentials integration with Vault.
    Please fix very soon!
     
  18. OSX does not come with wget by default.
     
  19. Nice work as always :)
     
Thread Status:
Not open for further replies.

Share This Page