Bukkit, CraftBukkit & Spigot 1.11 Released

Discussion in 'News and Announcements' started by md_5, Nov 17, 2016.

Thread Status:
Not open for further replies.
  1. do you have an application that may be is blocking it like an antivirus? xD
  2. i tried with antivirus off, still the same. He is building bukkit, succesfull than craftbukkit build succesfull and than stops, also haven't the target map in spigot.
  3. Thanks for all the hard work guys! I think it's amazing how quickly you guys managed to release this version after the official release (less than one week :eek:). The whole thing just finished compiling on my FreeBSD server, and I can't wait to give this a test run :)
  4. Why dont can you upload the ready spigot.jar
  5. gifs that problems with minecraft?
  6. I am sorry for being such a noob, but I am getting an error trying to run the command on ubuntu 16.04

    Getting the following error:
    Exception in thread "main" org.eclipse.jgit.api.errors.TransportException: https://hub.spigotmc.org/stash/scm/spigot/spigot.git: cannot open git-upload-pack

    Exception in thread "main" org.eclipse.jgit.api.errors.TransportException: https://hub.spigotmc.org/stash/scm/spigot/bukkit.git: cannot open git-upload-pack
    at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:135)
    at org.eclipse.jgit.api.CloneCommand.fetch(CloneCommand.java:202)
    at org.eclipse.jgit.api.CloneCommand.call(CloneCommand.java:135)
    at org.spigotmc.builder.Builder.clone(Builder.java:636)
    at org.spigotmc.builder.Builder.main(Builder.java:183)
    Caused by: org.eclipse.jgit.errors.TransportException: https://hub.spigotmc.org/stash/scm/spigot/bukkit.git: cannot open git-upload-pack
    at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:510)
    at org.eclipse.jgit.transport.TransportHttp.openFetch(TransportHttp.java:288)
    at org.eclipse.jgit.transport.FetchProcess.executeImp(FetchProcess.java:136)
    at org.eclipse.jgit.transport.FetchProcess.execute(FetchProcess.java:122)
    at org.eclipse.jgit.transport.Transport.fetch(Transport.java:1179)
    at org.eclipse.jgit.api.FetchCommand.call(FetchCommand.java:128)
    ... 4 more
    Caused by: java.net.SocketException: Network is unreachable (connect failed)
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
    at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
    at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
    at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
    at java.net.Socket.connect(Socket.java:589)
    at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:668)
    at sun.net.NetworkClient.doConnect(NetworkClient.java:175)
    at sun.net.www.http.HttpClient.openServer(HttpClient.java:432)
    at sun.net.www.http.HttpClient.openServer(HttpClient.java:527)
    at sun.net.www.protocol.https.HttpsClient.<init>(HttpsClient.java:264)
    at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:367)
    at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:191)
    at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1181)
    at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1032)
    at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:177)
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1546)
    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1474)
    at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480)
    at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:338)
    at org.eclipse.jgit.transport.http.JDKHttpConnection.getResponseCode(JDKHttpConnection.java:98)
    at org.eclipse.jgit.util.HttpSupport.response(HttpSupport.java:190)
    at org.eclipse.jgit.transport.TransportHttp.connect(TransportHttp.java:461)
    ... 9 more

    I am new to this, so I dont really know how to read the message/figure out what to do.
    #206 iJordi, Nov 22, 2016
    Last edited: Nov 22, 2016
  7. The first thing coming to my mind: do you have Git installed? Now, it's been ages since I've used Ubuntu but from mind you should be able to use: 'dpkg-query -l git', if that doesn't show any package names then you probably don't have it installed. Also see the Buildtools wiki page for all the prerequisites.
  8. There's legal things behind it.
  9. Because Spigot isn't a completely new program, it's a modified version of the official Minecraft server. This means that the compiled version of Spigot contains minecraft-server.jar, which in turn means that distributing pre-compiled Spigot jar files would also count as distributing minecraft-server.jar. Mojang's EULA says that nobody is allowed to distribute minecraft-server.jar except them, regardless of modifications, and that's a good thing.

    If I were to post a minecraft-server.jar, I could alter it so that it would allow me to join servers running my version even if I were banned, execute attacks against player accounts, or any number of other Very Bad Things ©. Nobody would know that I had done this unless they decompiled my version and went through tens of thousands of lines of code.

    As a (completely legal) workaround, Spigot doesn't distribute compiled versions of the server. They distribute BuildTools, which is a collection of scripts to download minecraft-server.jar from Mojang, as well as all of the Bukkit and Spigot changes from the Spigot team's repos, and compile it all into the Spigot jar.
    • Useful Useful x 1
  10. is it open source
  11. Try to avoid double-posting in the future, as it's considered poor forum etiquette pretty much everywhere on the internet.

    To answer your question, Spigot (and Bukkit before it, copyright issues notwithstanding) have always been open source. Everything related to development (for Spigot and plugins) can be found at http://hub.spigotmc.org, though you'll need to submit some paperwork if you wish to contribute to Spigot itself (because of the DMCA fiasco that hit Bukkit a couple years ago).
    • Like Like x 1
  12. Is there a download link to the spigot/craftbukkit 1.11?? Can't find it.
  13. As I detailed a few posts above yours, there are legal reasons for there not being any official precompiled Spigot downloads. Go to the Spigot wiki and look up BuildTools. There are easy-to-follow instructions there on how to get Git and BuildTools and how to use them to compile Spigot for yourself. This is the only trustworthy way to get Spigot, as (illegally-distributed) precompiled versions may have malicious changes in them.
  14. Hey guys, just wondering is there any easy way to disable this message and bypass the 30 second wait...

    *** Error, this build is outdated ***
    *** Please download a new build as per instructions from https://www.spigotmc.org/ ***
    *** Server will start in 30 seconds ***

    I'm running 1.11 and currently in the process of updating plugins, of course there is a lot of restarting of minecraft involved and it would speed things up heaps if I could turn this error message off.

    Sorry if this is the incorrect place to post this issue.

    BTW good work with the update :)
  15. I just updated my server to the latest 1.11 build, and whenever someone joins they get this error:
    Internal Exception: io.netty.handler.codec.Decoder.Exception: com.google.gson.JsonSyntaxException: com.google.stream.MalformedJsonException: Use JsonReader.setLenient(true) to accept malformed JSON at line 1 column 1

    Any ideas? I cant find anything online about this error or what could cause it.
  16. Yes i couldn't even wait for this! :D
  17. Do what it says and run BuildTools again to get a new build.

    Because 1.11 was released so recently, all the current builds expire after a couple days (as detailed in the announcement post) to make sure that people are using the latest builds. A decent-sized chunk of the Spigot team's time during recent releases was taken up by responding to reports for bugs that had already been fixed in newer builds for the same Minecraft version, hence the build expiration to get people's attention.
    • Agree Agree x 1
  18. Well, it says what's wrong right there in the error. You have a malformed JSON file somewhere. Check any files you've modified by hand and run them through a JSON syntax checker (find one with Google). You could also try checking your server logs to see if there's a console error to go with the client error; if there is an error, it may help you figure out which file isn't formatted correctly.
Thread Status:
Not open for further replies.

Share This Page