Bukkit, CraftBukkit & Spigot 1.11 Released

Discussion in 'News and Announcements' started by md_5, Nov 17, 2016.

Thread Status:
Not open for further replies.
  1. so i try to run buildtools newest version. on my dedi windows server and i get this error any help?
    Code (Text):
    Successfully fetched updates!
    Checked out: de459a282d9f494bbc5588b461b3e8eacd74f744
    Attempting to build Minecraft with details: VersionInfo(minecraftVersion=1.10.2, accessTransforms=bukkit-1.10.2.at, classMappings=bukkit-1.10.2-cl.csrg, memberMappings=bukkit-1.10.2-members.csrg, packageMappings=package.srg, minecraftHash=41c4e081defd80b09cb0391c894c2f3c, decompileCommand=java -jar BuildData/bin/fernflower.jar -dgs=1 -hdc=0 -asc=1 -udv=0 {0} {1})
    Found good Minecraft hash (41c4e081defd80b09cb0391c894c2f3c)
    Found good Minecraft hash (41c4e081defd80b09cb0391c894c2f3c)
    Final mapped jar: work\mapped.1ae486b6.jar does not exist, creating!
    Error occurred during initialization of VM
    Unable to allocate 524032KB bitmaps for parallel garbage collection for the requested 16769024KB heap.Error: Could not create the Java Virtual Machine.

    Error: A fatal exception has occurred. Program will exit.
    Exception in thread "main" java.lang.RuntimeException: Error running command, return status !=0: [java, -jar, BuildData/bin/SpecialSource-2.jar, map, -i, work\minecraft_server.1.10.2.jar, -m, BuildData/mappings/bukkit-1.10.2-cl.csrg, -o, work\mapped.1ae486b6.jar-cl]
        at org.spigotmc.builder.Builder.runProcess(Builder.java:552)
        at org.spigotmc.builder.Builder.main(Builder.java:310)
     
  2. Wow, that's quite awesome. Even the 1.11 test-server was very stable, thanks to everyone who is involved in this version! Great work.
     
    • Like Like x 1
  3. AHH oke i will wait. good to know it was not on my end :p thanks!
     
  4. SlimeDog

    Patron

    Instead of diving though hoops, and creating the potential for a .m2.xml that has incorrect references in future (which you're likely to forget you forged yourself), just wait until SpigotMC fixes the standard repo references. All will be well. :)
     
  5. where is ~/.m2/ ??? in windows

    oks C:\Documents and Settings\{your-username}\.m2
     
  6. I will just delete the settings.xml file (sinces its only overriding repos) if it gives me issues later. At least I am playing 1.11 now.
     
    • Like Like x 1
  7. Same error with --rev 1.11 option.

     
  8. You're so beautiful person answering me. Thank you! I must have skipped reading it if that was posted anywhere because I'm sneaking on here at work >.>

    I'm so responsable~ haha
     
  9. anyone know where to look if it is fixed?
     
  10. For those of us who compile on Windows, here is how to implement the maven-solution from @bbb001:
    Tagging: @TheKitleesi, @SlimeDog, @janpan and @AlanZ

    Run BuildTools as you normally would. You will get the error again, but you will be left with a few folders in your BuildTools directory. Go into the folder called "apache-maven-3.2.5", and edit the file "settings.xml" in notepad (or any other text editor).

    Remove everyting and paste the XML-document provided by @bbb001:
    Code (Text):
    <settings>
      <activeProfiles>
        <!--make the profile active all the time -->
        <activeProfile>securecentral</activeProfile>
      </activeProfiles>
      <profiles>
        <profile>
          <id>securecentral</id>
          <!--Override the repository (and pluginRepository) "central" from the
             Maven Super POM -->
          <repositories>
            <repository>
              <id>central</id>
              <url>https://repo1.maven.org/maven2</url>
              <releases>
                <enabled>true</enabled>
              </releases>
            </repository>
          </repositories>
          <pluginRepositories>
            <pluginRepository>
              <id>central</id>
              <url>https://repo1.maven.org/maven2</url>
              <releases>
                <enabled>true</enabled>
              </releases>
            </pluginRepository>
          </pluginRepositories>
        </profile>
      </profiles>
    </settings>
    Save and close it. Run BuildTools again, but DO NOT delete any of the files generated from the last run. It should now compile normally.
     
    • Winner Winner x 1
    • Useful Useful x 1
  11. I did not find settings.xml on apache-maven-3.2.5 i did edit settings.xml on C:\Documents and Settings\{your-username}\.m2
    and paste the code there and it works fine now I have the latest spigot running xD


    EDIT:
    actually it was C:\Users\{your-username}\.m2 lol it depends on what windows you are using I guess xD
     
    • Like Like x 1
  12. The location for settings.xml will probably be different if you are already using Maven on your computer. I am not, and therefore BuildTools will download it for me, and put it in the build folder.
     
  13. Wont work for me :( idk why still getting errors. i will wait till they fix the original builds
     
  14. oh hehehe that is true I using it on ecliple for plugins xD
     
  15. How I fix certificate issue:
    Open apache-maven-3.2.5/lib/maven-model-builder-3.2.5.jar in file archiver.
    Change in /org/apache/maven/model/pom-4.0.0.xml:
    Code (Text):
    <url>https://repo.maven.apache.org/maven2</url>
    to
    Code (Text):
    <url>https://repo1.maven.org/maven2</url>
    in both places.
    Save file.
    Run java -jar BuildTools.jar --rev 1.11
     
    • Agree Agree x 1

  16. IF this actually work it is the best solution as far now xD
    as I already have the latest version right now I have not tested but it appears logical that will work xD
     
  17. I don't even know what's going on with my build. Have tried on three different computers....at first it was all the same maven error but one of the builds finally made it past that (unsure how, it worked before I had the ability to use the work around above). Then it was a new error set. Then a new error set. I don't even know what is going on anymore....the most recent issue was with the API. And as I was writing this it finished compiling them all correctly. I'm so confused.
     
  18. Problem should be fixed know, no errors anymore...
     
    • Agree Agree x 1
  19. #160 Proximyst, Nov 18, 2016
    Last edited: Nov 18, 2016
Thread Status:
Not open for further replies.