Bukkit, CraftBukkit & Spigot 1.8.6

Discussion in 'News and Announcements' started by md_5, May 25, 2015.

Thread Status:
Not open for further replies.
  1. Damn, fast updates.

    Spigot seems to be having closer ties with Mojang, than they did probably about a couple years ago. After the next couple announcements it's going to be:

    "md_5 and ThinkofDeath hired by Mojang" :p
     
    • Like Like x 1
  2. Wow, thanks for the fast release; you guys are amazing! You're on these Minecraft updates like me when my server crashes.
     
  3. Yeah, but there are many NMS plugins still on 1.8.3. What is the problem if we stay with 1.8.3 for a few weeks?
     
  4. md_5

    Administrator Developer

    Or the updates are just really small.
    1.8.5 ->1 8.6:
    34 files changed, 83 insertions(+), 141 deletions(-)
     
    • Like Like x 4
  5. JamesJ

    Supporter

    1.9 cannot be far away... horray...!
     
    • Agree Agree x 1
  6. I have two questions:
    1. How can you get the original minecraft servers code?
    2. How can you hook to this code so fast?

    Could you tell me all the softwares, that you are using for making these things so fast?
     
    • Agree Agree x 1
  7. You got it within 20 minutes! Good job Spigot!
    Time to compile spigot.... Later today lol when I'm home and not in the middle of a math test. :p
     
    • Like Like x 1
  8. It's memorial day... and why are you in the middle of a math test trying to go on spigot forums lol.
     
    • Agree Agree x 1
  9. md_5

    Administrator Developer

    Not everyone is American
     
    • Agree Agree x 8
    • Funny Funny x 1
  10. Forgot sorry
     
  11. Ever since 1.8.3 and forward I have been getting the "Can't obtain static newInstance method for class" error both when running the buildtools and if I run a server at some computers(this case servers). I can build and run server at my local computer but not the servers) There was a JIRA ticket(https://hub.spigotmc.org/jira/browse/BUILDTOOLS-100) for it but it was closed as "solved". Someone knows more then me? Seems im not only one getting these errors. Also seems related to a i3/i5 processor information that seems to be hard to fetch from Registry.

    Suggestions?
     
  12. md_5

    Administrator Developer

    Open a new ticket and include information about your OS.
     
  13. I'm Canadian. Lol.

    I had last Monday off, and I get this Friday off.
     
  14. Minecraft 1.8.123456789 is released!
     
    • Funny Funny x 5
  15. Or 1.8.6.17273738.3626.28262829.2727352819262928.123455677890002.1727483.1.2838.83836.2836393

    THAT IS THE NEXT Version.. :p
     
    • Agree Agree x 1
    • Optimistic Optimistic x 1
  16. saphiria

    Artist

    Thanks! I really appreciate your updates! :)
     
    • Agree Agree x 1
  17. #md_5ForMojangDev
     
    • Like Like x 1
  18. Minecraft Version 3.14159265359 will be the last Minecraft version. :D
     
    • Funny Funny x 1
  19. I'm curious about the security flaws too, i'm still running 1.8.3, will update soon but is there something i should be worried about?
    There is no info on what those problems were.
     
Thread Status:
Not open for further replies.