Bukkit, CraftBukkit & Spigot 1.8

Discussion in 'News and Announcements' started by md_5, Nov 28, 2014.

Thread Status:
Not open for further replies.
  1. OH NVM! It is. It loads up a spigot-1.8.jar file right? Also is there a 1.7/1.8 Build?
     
  2. Buildtools.jar builds spigot, and bukkit. There is a 1.8 protocol hack for the last released version for 1.7.10, but we can not give you a link to it (the version of spigot that is). Do check your PMs. The protocol hack should be listed in resources.
     
  3. I get that too, i banned the player called FindAServer and he keeps trying to connect every day like 20 times? Who the fuck is this annoying asshole?

    [13:39:09 INFO]: [email protected][id=900611fe-f668-390c-a
    eb6-8ad71d743fc0,name=FindAServer,properties={},legacy=false] (/212.48.79.173:42
    991) lost connection: You are banned from this server!
     
  4. I am having trouble. I compiled it all and I am fairly sure that went all fine. I went into Downloads > CraftBukkit > target > and got "original-craftbukkit-1.8-R0.1-SNAPSHOT.jar". Since I am renting a server, I opened up Filezilla and put "original-craftbukkit-1.8-R0.1-SNAPSHOT.jar" into the jar folder. All went fine.
    However, when I start up my server, it fails to start and I get an error in the console saying:
    21.01 15:20:37 [Server] INFO at net.minecraft.server.v1_8_R1.MinecraftServer.y(MinecraftServer.java:598) [original-craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-1092acb]
    21.01 15:20:37 [Server] INFO at net.minecraft.server.v1_8_R1.DedicatedServer.z(DedicatedServer.java:284) [original-craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-1092acb]
    21.01 15:20:37 [Server] INFO at net.minecraft.server.v1_8_R1.MinecraftServer.z(MinecraftServer.java:653) [original-craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-1092acb]
    21.01 15:20:37 [Server] INFO at org.bukkit.craftbukkit.v1_8_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:349) [original-craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-1092acb]
    21.01 15:20:37 [Server] INFO at org.bukkit.craftbukkit.v1_8_R1.scheduler.CraftTask.run(CraftTask.java:53) ~[original-craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-1092acb]
    21.01 15:20:37 [Server] INFO at com.massivecraft.massivecore.ModuloRepeatTask.run(ModuloRepeatTask.java:76) ~[?:?]
    21.01 15:20:37 [Server] INFO at com.massivecraft.factions.task.TaskPlayerPowerUpdate.invoke(TaskPlayerPowerUpdate.java:43) ~[?:?]
    21.01 15:20:37 [Server] INFO java.lang.NoSuchMethodError: org.bukkit.Bukkit.getOnlinePlayers()[Lorg/bukkit/entity/Player;
    21.01 15:20:37 [Server] INFO [15:20:37 WARN]: [Factions] Task #28 for Factions v2.7.1 generated an exception
    21.01 15:20:37 [Server] INFO at java.lang.Thread.run(Unknown Source) [?:1.8.0_05]
    21.01 15:20:37 [Server] INFO at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:506) [original-craftbukkit-1.8-R0.1-SNAPSHOT.jar:git-Bukkit-1092acb]
    I am guessing I am doing something wrong, as I am not the most experienced guy with this kinda stuff.
    Is there anyone who could help me?
     
  5. Thinkofdeath

    Thinkofdeath Retired Developer
    Retired

    @Tuggers03 Thats because you are running the wrong jar. You want either craftbukkit-1.8.jar or spigot-1.8.jar that will appear next to your buildtools.jar once the build is completed
     
  6. Aha, silly me. I've got it. Thanks a lot. :)
     
  7. 2452*
     
  8. When will further development of Essentials continue?
     
  9. ssamjh

    Moderator

    As far as I know, the offical Bukkit page for it is dead and unmaintained, as it states
    "There is no official Bukkit for Minecraft 1.8
    There is no official Essentials for Minecraft 1.8
    "


    I suppose we are relying on md_5 and the crew to keep it updated for us.
     
  10. here
     
  11. How do you run the server?
     
  12. Thank you for all! Your work is amazing! I hope i can use this version in my server soon ;)
     
  13. Awesome! Thank you!
     
  14. When will the OS X version come out?
     
  15. It did on the page here it says "Finish up Mac OSX support, require Java 7 for BuildTools." so just put it in a folder and java -jar it or if that doesn't work double clicking may work.(Use the latest build tools.jar, #25.)
     
  16. Then what do I do and if I am using MCPH do I select Spigot or Bukkit?
     
  17. why it's a error?

    [​IMG]

    Thank you :>
     
  18. Attached Files:

    #2559 Basti84, Jan 26, 2015
    Last edited: Jan 26, 2015
  19. 2 Problems: a) path with a space and b) you are under program files wchich is treated differently by windows in terms of who can write data inside.
    try to do the stuff under C:\spigot or similar path
     
Thread Status:
Not open for further replies.