Bukkit, CraftBukkit & Spigot 1.8

Discussion in 'News and Announcements' started by md_5, Nov 28, 2014.

Thread Status:
Not open for further replies.
  1. Is it possible To update the id in essential plugins, for the new potion
     
  2. md_5

    Administrator Developer

    Are you using Spigot-Essentials?
     
  3. How could I do that? Do I type in the whole C:\Program Files (x86)\Java\jre1.8.0_31\bin\java.exe or what?
     
  4. yeah, thats what you have to do
     
  5. Finally i have a bit of understanding of all the changed and everything. but still, is the actual bukkit ever going to be as it was?
     
  6. Do you mean will Bukkit/CraftBukkit ever be created again by the original team? The answer is no. They all quit in an extremely childish hissy-fit.
     
  7. And that's the same probleme for all new items, example the Diorite as the same short name to stone.
     
  8. A post spammer at its finest.
     
    • Agree Agree x 1
  9. ?
     
  10. [​IMG]
     
  11. http://pastebin.com/8Em5mjVB
    It crashes my whole computer at the very last moments (when i "open" the buildtool file with a shell etc. ) and it won't make the "spigot snapshot jar file"

    PLZ help:(
     
  12. Whats the difference in spigot jars that were created?
    original-spigot-1.8-RO.1-SNAPSHOT.jar
    spigot-1.8-RO.1-SNAPSHOT.jar
    spigot-1.8-RO.1-SNAPSHOT-remapped.jar
     
  13. original-spigot-1.8-RO.1-SNAPSHOT.jar is before the jar is shaded.
    spigot-1.8-RO.1-SNAPSHOT-remapped.jar is with mappings.
    spigot-1.8-RO.1-SNAPSHOT.jar is the final jar with everything you need.
     
  14. Thanks
     
  15. I have a question. I know that that Spigot 1.8 doesn't support 1.7.10 but I was wondering if there is any build that supports 1.7.10 and has all of the 1.8 features.
     
  16. I think their is a way to make it so your in 1.7 but you have 1.8 features you would have to ask a dev about it.
     
  17. No, you can protocol hack a 1.7.10 server to allow 1.8 clients to connect to it but you cannot do the other way around. The 1.7.10 client knows nothing about the new blocks and items in the 1.8 server, this is just not possible without client update.
     
    • Like Like x 1
Thread Status:
Not open for further replies.