Bukkit, CraftBukkit & Spigot 1.8

Discussion in 'News and Announcements' started by md_5, Nov 28, 2014.

Thread Status:
Not open for further replies.
  1. can i still be on 1.8 spigot and have the protocolhack
     
  2. I've found that 1.8 and the protocol hack can cause issues with some plugins. Also, to be honest, why would you want the hack with 1.8? players just need to set the launcher to latest? It's different when you need the backward compatibility of latest launcher to a 1.7 server. I'm presuming 1.7 clients would struggle with the 1.8 blocks already on the server etc?
     
  3. I cant belived, is really, finally!!!! 1.8 for all !!!
     
    • Friendly Friendly x 1
  4. Are these warnings normal? Don't know how to solve it

    Code (Text):

    WARN:  Inconsistent inner class entries for net/minecraft/server/BlockMonsterEggs$EnumMonsterEggVarient!
    WARN:  Inconsistent inner class entries for net/minecraft/server/BlockMonsterEggs$EnumMonsterEggVarient!
    WARN:  Inconsistent inner class entries for net/minecraft/server/BlockMonsterEggs$EnumMonsterEggVarient!
    WARN:  Inconsistent inner class entries for net/minecraft/server/BlockMonsterEggs$EnumMonsterEggVarient!

    [WARNING] guava-17.0.jar, minecraft-server-1.8.3-SNAPSHOT.jar define 1686 overlappping classes:
    [WARNING]   - com.google.common.collect.ImmutableMapValues$1
    [WARNING]   - com.google.common.io.LineProcessor
    [WARNING]   - com.google.common.util.concurrent.AbstractService$5
    [WARNING]   - com.google.common.io.BaseEncoding$StandardBaseEncoding$2
    [WARNING]   - com.google.common.io.ByteProcessor
    [WARNING]   - com.google.common.math.package-info
    [WARNING]   - com.google.common.util.concurrent.SimpleTimeLimiter
    [WARNING]   - com.google.common.io.GwtWorkarounds$5
    [WARNING]   - com.google.common.cache.AbstractCache$StatsCounter
    [WARNING]   - com.google.common.util.concurrent.CycleDetectingLockFactory$Policies
    [WARNING]   - 1676 more...
    [WARNING] craftbukkit-1.8.3-R0.1-SNAPSHOT.jar, minecraft-server-1.8.3-SNAPSHOT.jar define 493 overlappping classes:
    [WARNING]   - org.apache.logging.log4j.core.appender.ConsoleAppender$ConsoleManagerFactory
    [WARNING]   - net.minecraft.server.DispenserRegistry$2
    [WARNING]   - net.minecraft.server.DispenserRegistry$12
    [WARNING]   - net.minecraft.server.PathfinderGoalNearestAttackableTargetInsentient
    [WARNING]   - net.minecraft.server.PathfinderGoalHurtByTarget
    [WARNING]   - net.minecraft.server.Entity$4
    [WARNING]   - net.minecraft.server.BlockGrass
    [WARNING]   - net.minecraft.server.Chunk$1
    [WARNING]   - net.minecraft.server.EntityHuman
    [WARNING]   - net.minecraft.server.BlockPressurePlateBinary$EnumMobType
    [WARNING]   - 483 more...
    [WARNING] gson-2.2.4.jar, minecraft-server-1.8.3-SNAPSHOT.jar define 153 overlappping classes:
    [WARNING]   - com.google.gson.internal.bind.JsonTreeWriter
    [WARNING]   - com.google.gson.internal.Excluder
    [WARNING]   - com.google.gson.JsonDeserializationContext
    [WARNING]   - com.google.gson.internal.$Gson$Types
    [WARNING]   - com.google.gson.internal.LinkedTreeMap$KeySet
    [WARNING]   - com.google.gson.FieldNamingPolicy$5
    [WARNING]   - com.google.gson.internal.bind.SqlDateTypeAdapter$1
    [WARNING]   - com.google.gson.internal.UnsafeAllocator$2
    [WARNING]   - com.google.gson.FieldAttributes
    [WARNING]   - com.google.gson.internal.$Gson$Types$ParameterizedTypeImpl
    [WARNING]   - 143 more...
    [WARNING] maven-shade-plugin has detected that some .class files
    [WARNING] are present in two or more JARs. When this happens, only
    [WARNING] one single version of the class is copied in the uberjar.
    [WARNING] Usually this is not harmful and you can skeep these
    [WARNING] warnings, otherwise try to manually exclude artifacts
    [WARNING] based on mvn dependency:tree -Ddetail=true and the above
    [WARNING] output
    [WARNING] See http://docs.codehaus.org/display/MAVENUSER/Shade+Plugin

    WARNING] spigot-1.8.3-R0.1-SNAPSHOT.jar, minecraft-server-1.8.3-SNAPSHOT.jar define 557 overlappping classes:
    [WARNING]   - org.apache.logging.log4j.core.appender.ConsoleAppender$ConsoleManagerFactory
    [WARNING]   - net.minecraft.server.DispenserRegistry$2
    [WARNING]   - net.minecraft.server.DispenserRegistry$12
    [WARNING]   - net.minecraft.server.PathfinderGoalNearestAttackableTargetInsentient
    [WARNING]   - net.minecraft.server.PathfinderGoalHurtByTarget
    [WARNING]   - net.minecraft.server.Entity$4
    [WARNING]   - net.minecraft.server.BlockGrass
    [WARNING]   - net.minecraft.server.Chunk$1
    [WARNING]   - net.minecraft.server.EntityHuman
    [WARNING]   - net.minecraft.server.BlockPressurePlateBinary$EnumMobType
    [WARNING]   - 547 more...
    [WARNING] guava-17.0.jar, minecraft-server-1.8.3-SNAPSHOT.jar define 1686 overlappping classes:
    [WARNING]   - com.google.common.collect.ImmutableMapValues$1
    [WARNING]   - com.google.common.io.LineProcessor
    [WARNING]   - com.google.common.util.concurrent.AbstractService$5
    [WARNING]   - com.google.common.io.BaseEncoding$StandardBaseEncoding$2
    [WARNING]   - com.google.common.io.ByteProcessor
    [WARNING]   - com.google.common.math.package-info
    [WARNING]   - com.google.common.util.concurrent.SimpleTimeLimiter
    [WARNING]   - com.google.common.io.GwtWorkarounds$5
    [WARNING]   - com.google.common.cache.AbstractCache$StatsCounter
    [WARNING]   - com.google.common.util.concurrent.CycleDetectingLockFactory$Policies
    [WARNING]   - 1676 more...
    [WARNING] gson-2.2.4.jar, minecraft-server-1.8.3-SNAPSHOT.jar define 153 overlappping classes:
    [WARNING]   - com.google.gson.internal.bind.JsonTreeWriter
    [WARNING]   - com.google.gson.internal.Excluder
    [WARNING]   - com.google.gson.JsonDeserializationContext
    [WARNING]   - com.google.gson.internal.$Gson$Types
    [WARNING]   - com.google.gson.internal.LinkedTreeMap$KeySet
    [WARNING]   - com.google.gson.FieldNamingPolicy$5
    [WARNING]   - com.google.gson.internal.bind.SqlDateTypeAdapter$1
    [WARNING]   - com.google.gson.internal.UnsafeAllocator$2
    [WARNING]   - com.google.gson.FieldAttributes
    [WARNING]   - com.google.gson.internal.$Gson$Types$ParameterizedTypeImpl
    [WARNING]   - 143 more...
    [WARNING] maven-shade-plugin has detected that some .class files
    [WARNING] are present in two or more JARs. When this happens, only
    [WARNING] one single version of the class is copied in the uberjar.
    [WARNING] Usually this is not harmful and you can skeep these
    [WARNING] warnings, otherwise try to manually exclude artifacts
    [WARNING] based on mvn dependency:tree -Ddetail=true and the above
    [WARNING] output
    [WARNING] See http://docs.codehaus.org/display/MAVENUSER/Shade+Plugin

    [WARNING]
    [WARNING] Some problems were encountered while building the effective model for org.spigotmc:spigot-api:jar:1.8.3-R0.1-SNAPSHOT
    [WARNING] 'parent.relativePath' points at org.spigotmc:spigot-parent instead of org.sonatype.oss:oss-parent, please verify your project structure @ line 6, column 13
    [WARNING]
    [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
    [WARNING]
    [WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
    [WARNING]
     
    And about the maven warning is it not as there is a newer version 3.2.5?
     
  5. md_5

    Administrator Developer

    Thats normal, you will get your jars at the end.
     
    • Like Like x 1
  6. Ok will that be fixed or is it something that can't be fixed? I just wondered :oops:
     
  7. Thanks great work i love spigot team!
     
  8. jflory7

    Retired Benefactor

Thread Status:
Not open for further replies.

Share This Page