Bukkit, CraftBukkit & Spigot 1.8

Discussion in 'News and Announcements' started by md_5, Nov 28, 2014.

Thread Status:
Not open for further replies.
  1. MostFunGuy

    Supporter

    .... What?
     
  2. Tried to bypass OS X check... no success. Jacobe isn't available for OS X :(
     
  3. md_5

    Administrator Developer

    Yup, thats the issue.
     
    • Informative Informative x 1
  4. Same here, getting bukkit and craftbukkit target folders, but no "Spigot/Spigot-Server/target" folder here either.
     
    • Agree Agree x 2
  5. Can't wait until I see the future of Spigot!
     
  6. md_5

    Administrator Developer

    Where does the console end? Do you see Spigot compiling?
     
  7. Me aswell...
     
  8. Hello !

    Protocollib work for you? and JSONAPI ?
     
  9. I'll run BuildTools again to update and get that info
     
  10. I'm having some issues and keep getting the message

    ./BuildTools.jar: ./BuildTools.jar: cannot execute binary file

    Does anyone know what I may be doing wrong?
     
  11. md_5

    Administrator Developer

    java -jar BuildTools.jar

    Please read the instructions
     
  12. Wow! Great work guys!
     
  13. Eh not sure whats wrong here.

    Code (Text):
    :~$ java -jar BuildTools.jar
    BuildTools
    unconfigured@null.spigotmc.org
    Exception in thread "main" org.eclipse.jgit.errors.RepositoryNotFoundException: repository not found: /home/admin/Spigot at org.eclipse.jgit.lib.BaseRepositoryBuilder.build(BaseRepositoryBuilder.java:575)
            at org.eclipse.jgit.api.Git.open(Git.java:113)
            at org.eclipse.jgit.api.Git.open(Git.java:97)
            at org.spigotmc.builder.Builder.main(Builder.java:130)
     
    I've got a spigot.jar in the spigot folder but it's looking like a 1.7.10 build in the console.
     
  14. I promise I am not trying to sound rude but I am honestly confused. I did read the instructions, in fact I copy and pasted every line I could to try and avoid mistakes.
     
  15. BuiltTools.jar worked flawlessly for me. As I mentioned earlier, I have my test server running and am going through and marking plugins that I'll need to update. Am getting some tile entity placement exceptions, strangely, but everything else is as expected. I'm still impressed that this was pulled off under these conditions.
     
  16. md_5

    Administrator Developer

    Hm, is there a folder named: "Spigot" exactly, in the same folder as your jar.
    Instead of running ./BuildTools.jar run: java -jar BuildTools.jar
     
    • Like Like x 1
  17. It doesn't seem to create the /Spigot/Spigot-Server/target folder, The Git Bash closes itself so I can't see the error and no logs are found.
    It closes while Remapping Final Jar, a few (20-30) tasks get remapped but then randomly crashed and shows a quick exception which cant be red in time.

    OS: Windows 7 (64bit)
     
  18. Mac OS X restrictions won't stop me. Just use a virtual machine and it will work fine ;)
     
    • Informative Informative x 1
  19. Mob Spawners appear to be broken using /i and /give, just spawning pigs on placement now,.
     
  20. Thank you so much that appears to be working now. I'm using windows so I was trying to use the windows commands but apparently the linux commands work just fine. Thank you so much!
     
Thread Status:
Not open for further replies.

Share This Page