Bukkit, CraftBukkit & Spigot 1.8

Discussion in 'News and Announcements' started by md_5, Nov 28, 2014.

Thread Status:
Not open for further replies.
  1. Its all the same...Were using Java...Has nothing to do with Windows except for the way Windows reads the Java Home....and constantly eat up system memory.... Pet peve :)
  2. I'm on windows 8.1
  3. lol u have pants?
    • Funny Funny x 1
  4. http://i.gyazo.com/9792eca8e1711977f5ad42a239d387ed.png

    Centos OS, 64 bit. Did install Git, whatever it is, dont know what to do? The git commands dont seem work, or i'm doing it fatally wrong. Enter them by themselves? "Fatal: Not a git respitory (or any of the parent directories): .git
  5. It looks like your trying to run the uncompiled version....
  6. If you can't manage this... you really have no business running a server, and are the precisely target audience of Realms.

    Oh, and trying to compare the hashes of binaries built in different environments? Funniest thing I've seen all day. And to illustrate my point, I went and built this on my server, twice. These are the hashes I received:

    This is using exactly the same environment, in which the only major difference is the time at which the jars were built.
    #1108 hatstand, Nov 29, 2014
    Last edited: Nov 29, 2014
    • Agree Agree x 1
  7. IDK...Why do you have to Run it as Root? not a good idea IMHO.
  8. When I try to double click buildtools, nothing happens, so I tried this in the command prompt, and well, I don't know what to do:

  9. I'm not sure if it's just my PC or what, but when I run the compile process exactly as the instructions state, I can not locate the Spigot server .jar file anywhere. I could provide screenshots, or could someone offer a download to a complied build?
  10. Based on what you just wrote..Give up and Join Realms....Since when do you double click a Jar file?...besides your client.
    • Agree Agree x 1
  11. how fix it?
    • Funny Funny x 1
  12. Its buried deep in the folder you ran buildtools in under a directory under spigot called Target. Here's where mine ended up.../home/steve/Downloads/Spigot1.8/Spigot/Spigot-Server/target/
  13. Why I can't find any jar files???

    Attached Files:

  14. I keep getting an error when it tries to remap the final jar:

    I have tried different heap sizes as I saw that in there but nothing works!
  15. I don't see your buildtools.jar in that directory...find it.
  16. Use a Xmx 3G flag in your command line...that should be enough.
  17. What version of GroupManager should I be using with this?
    • Agree Agree x 1
Thread Status:
Not open for further replies.