Bukkit, CraftBukkit & Spigot 1.8

Discussion in 'News and Announcements' started by md_5, Nov 28, 2014.

Thread Status:
Not open for further replies.
  1. I've never compiled anything, and I don't have a player base, but I could do it, so it must be pretty easy. =)
     
  2. Since there is over 50 pages saying "thanks"...

    Thank you for updates and especially the source code. When the updates were patches, I was sceptic about the future of Spigot, but now I can trust it will developed. Probably...

    And about jar files, its very likely that someone will compile them for you :) Hashes for 1.8 versions would be useful.
     
  3. And Yes it's error logs
     
    • Funny Funny x 1
  4. If any of you need help compiling it feel free to add me on Skype: gman200108
    Rendering a video tutorial right now.
     
  5. ...
    I believed I had updated my JDK. I believed wrongly. Works like a charm now...
     
    #1146 Yamiji, Nov 29, 2014
    Last edited: Nov 29, 2014
  6. Has anyone had issues with ChestShop not working? I recently had my chestshop setup and now it's just not working since I updated the server. Anyone else had this issue?
     
  7. The hosting companies will probably do that for them lol ;(
     
  8. If it finished in 2-3 minutes there was probably an error in your patch..
     
  9. Try ChestShop 3.7.18.
     
    • Like Like x 1
  10.  
    #1151 Gman200108, Nov 29, 2014
    Last edited: Nov 29, 2014
    • Like Like x 1
  11. I made a quick little video showing you the easiest way to extract from the jar. A Lot of people said it helped them out.
     
    • Agree Agree x 1
  12. Unfortunately, the author of Prism says he will not update his plugin for 1.8 because Spigot is "still distributing illegal code so we're not going to waste our time". Since Prism is covered by a CC license, maybe someone would be willing to make a fork for 1.8.
     
    • Informative Informative x 1
  13. First, @md_5, thank you. I run a small private server for my daughter and her friends. The kids have been having an absolute blast on MC 1.8 since I was able to load and run Spigot 1.8 and the updated Essentials/PermissionsEx. I regenerated the world, and everything works great.

    My host provided the compiled spigot.jar - thank goodness. However, I do my best to understand my own server. Again, no urgency here because I do have the compiled jar, I just want to do it myself. I've read this entire thread (yes every page!) trying to figure out this compile on my own. I have seen at least one other person with my issue but no solution offered. I am on Windows 7 (32-bit). I have downloaded and installed Java and Git. I placed the #8 version of BuildTools.jar in an empty folder existing in a path/directory structure that has no spaces. I used Git Bash to run the command JAVA_HOME="C:\Program Files (x86)\Java\jdk1.8.0_25" java -jar BuildTools.jar (yes, this is my confirmed path to Java). I have to repeatedly run this command at least 7 or 8 times while it creates the folders and downloads Maven incrementally. Finally, once Maven downloads and extracts, I can go no farther. I've redone this and tried other folders, to no avail. Any thoughts?


    Welcome to Git (version 1.9.4-preview20140929)


    Run 'git help git' to display the help index.
    Run 'git help <command>' to display help for specific commands.

    [email protected] /C/Users/ninjamommy/Downloads/Minecraft/Spigot/Updated_1.8/28Nov14BuildTools (master)
    $ JAVA_HOME="C:/Program Files (x86)/Java/jdk1.8.0_25/" java -jar BuildTools.jar
    BuildTools
    [email protected]
    Pulling updates for C:\Users\ninjamommy\Downloads\Minecraft\Spigot\Updated_1.8\28Nov14BuildTools\Bukkit\.git
    Exception in thread "main" org.eclipse.jgit.api.errors.JGitInternalException: In
    valid ref origin/master specified
    at org.eclipse.jgit.api.ResetCommand.call(ResetCommand.java:160)
    at org.spigotmc.builder.Builder.pull(Builder.java:301)
    at org.spigotmc.builder.Builder.main(Builder.java:140)

    [email protected] /C/Users/ninjamommy/Downloads/Minecraft/Spigot/Updated_1.8/28Nov14BuildTools (master)
    $
     
    • Like Like x 1
  14. Ok so I am very frustrated. I have been working for hours to get this to work.

    First off, I am using both a MacBookPro and iMac so to start with I have to use virtual servers to even attempt to build these. I allocate a good 5GB of RAM to take care of the Java process so I can fix the initial error I had before. Once I go above 1gb however, my JRE says that it can't create the virtual machine as their isn't enough memory. I checked in the server and current usages to see if I had enough and I did. What am I doing wrong? Can someone just do me the favor of posting the compiled jars until I can get this working for myself?
     
  15. Great work thanks!
     
  16. I am having a weird issue with a redstone sorter not working but only random chests will sort right the other stuff gose in to the catch all chest. Has anybody body else see any issues with redstone ? Or hoppers /chest trap chest setup
     
    #1157 Flakes33, Nov 29, 2014
    Last edited: Nov 29, 2014
  17. You can't build CraftBukkit or Spigot on Mac right now. :x
     
  18. He's running a Windows/Linux virtual machine, read the post.
     
  19. EntityData not working? I get back the UUID is not correct...
     
Thread Status:
Not open for further replies.